macOS app launch stalls after bootup

Description of the issue: After a restart, when I launch the Brave Browser.app the app is not available.

How can this issue be reproduced?

  1. Boot up the computer and launch the app, e.g. double clicking an app icon, or using Spotlight
  2. App does not come to the forefront
  3. App is not available scrolling through active apps w/ cmd+TAB
  4. Open Force Quit
  5. Don’t force quit Brave, but double click on the icon.
  6. Brave Browser.app is now available

Expected result: I’d expect the app to be available for use after launching it.

Brave Version( check About Brave):
Version 1.41.96 Chromium: 103.0.5060.114 (Official Build) (x86_64)

Additional Information: I have observed this behavior for the past several verssions

@mixelpix

Sounds like Brave Browser (‘BB’) is struggling with one or more connections and/or processes.

When BB runs well-enough for you to BOTH, Disable and Remove all Extensions, do that.

In a Brave Browser > New Window, go to: brave://settings/clearBrowserData

For tab Advanced:

  • Set: Time range:All time
  • Enable: Browsing history
  • Enable: Download history
  • Enable: Cookies and other site data (When Enabled, Signs you out of most sites)
  • Enable: Cached images and files
  • Disable: Passwords and other sign-in data (When Enabled, DELETES PASSWORDS)
  • Disable: Autofill form data
  • Disable: Site and Shields Settings (When Enabled, DELETES Shields Settings and RESTORES default: Shields UP for site-specific Shields [Lion icon] panel)
  • Enable: Hosted app data

Click on the ‘Clear data’ button.

(The ‘Clear data’ button also saves the selections.)

In a Brave Browser > New Window, go to: brave://settings/security

  • DISABLE: Use secure DNS

Recommended in order to reduce influence by websites:

In a Brave Browser - New Window, go to: brave://settings/content

Scroll down to Additional permission . . . and set:

  • Protocol handlers: Don't allow sites to handle protocols
  • File editing: Don't allow sites to edit files or folders on your device
  • Clipboard: Don't allow sites to see text or images on your clipboard
  • Window placement: Don't allow sites use info about your screens to open and place windows

Scroll down to Content . . . and set:

  • Pop-ups and redirects: Don't allow sites to send pop-ups or use redirects

Recommended, go to: brave://settings/cookies

  • Enable: Block third-party cookies
  • Disable: Clear cookies and site data when you close all windows
  • Do not use: Sites that clear cookies when you close them (better to clear those cookie sites/sources, manually: brave://settings/clearBrowserData)

Clearing DNS cache

In a Brave Browser > New Window, go to: brave://net-internals/#dns and click on:

  • Clear host cache

Next, go to: brave://net-internals/#sockets and click on both of the following (in succession):

  • Close idle sockets
  • Flush socket pools

Exit / Quit Brave Browser

Exit / Quit everything else and Restart your computer.

Notes re what are:

DNS cache:

Socket pool:

With pooling, instead of closing a connection after it is used, we can keep it idle while it waits to handle another request. This saves the resources required to create a new connection.

When running again, test, one-at-a-time, each Extension - the effect re launching Brave Browser.

PS. Might you have an anti-virus application and/or Internet security application, that could be frustrating BB?

Maybe a VPN?