Mac Users - Try Turning Hardware Acceleration ON

Hey Brave fam. I recently stumbled into a very net positive solution that has now made such a difference that it needs to be posted here. If you’re experiencing slow downs, choppy video, excessive CPU and memory use in Activity Monitor etc. try turning Hardware Acceleration ON. Just did this a week ago and since it’s made a massive difference.

So why am I posting about this?

Been using Brave on Mac OS since inception and it’s always been best with HA off. Usually I’ve got 18-20 project specific windows with ~100+ tabs spread evenly around. So these ill effects are very much to be expected. This is on me, not Brave. All unused tabs are kept minimized w/no more that 2-3 open at a time… but still, it gets rough.

Long story short, started searching for back-end tweaks and everything I found was of course about turning HA off, yet mine was already off. Figured why not and turned it on.

Huge improvement. Hope this helps some people out.

Mojave 10.14.6
MacBook Pro (Retina, 15-inch, Mid 2015)
2.8 GHz Intel Core i7
16 GB 1600 MHz DDR3
AMD Radeon R9 M370X 2 GB
Intel Iris Pro 1536 MB
Clamshell mode with dual monitors

Version 1.39.107 Chromium: 101.0.4951.67 (Official Build) dev (x86_64)
Brave rewards are completely disabled

1 Like

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.