Mac OS "Back" two-finger swipe gesture rarely works


#1

This is regarding the default Mac OS two-finger swipe gesture for navigating “Back”. It works flawlessly for Safari, but not for Brave. It has been this way since I discovered Brave over a year ago. It is totally random, unfortunately.

Video:
https://www.videosprout.com/video?id=9ec4dd27-e2c1-4258-89ac-73a0e57223d4

  • i. Operating System and version (Mac 10.13.6)

  • ii. Brave Version:
    Brave: 0.23.39
    V8: 6.7.288.46
    rev: 3ee14b026f09d7d71c1985b4a9c9a11d78ab8f49
    Muon: 7.1.6
    OS Release: 17.7.0
    Update Channel: Release
    OS Architecture: x64
    OS Platform: macOS
    Node.js: 7.9.0
    Brave Sync: v1.4.2
    libchromiumcontent: 67.0.3396.103

  • Detailed step-by-step instructions

    • i. I downloaded and installed Brave.
    • ii. I navigated to multiple pages.
    • iii. I tried to go “Back” to a few pages, using the two finger swipe gesture.
    • iv. The page moved a bit, and the little “Back” icon in the top left area of Brave would get larger, but the page would not go back. I’ve tested this multiple times. It works randomly, but very rarely. Sometimes a tab will work fine with the swipe gesture, but then other tabs won’t at all, no matter what I try doing. Other times it will require a massive gesture to finally get the page to go back, which is just silly.

This is a dealbreaker for me. I would love to switch to Brave as my main browser, but the unreliability of this behaviour is too big of a problem.

Otherwise, I love Brave and think you guys have done an amazing job, so keep up the great work and thank you. I look forward to using Brave as my main browser very soon!


#3

Hi @v0iD, I’m just so used to using two fingers to swipe, I don’t think a single finger swipe gesture is going to work for me. I’d just like the default OS swipe behaviour. I definitely don’t want to turn off any other gestures since I’m also so used to using those. I’d just like Brave to work like my other Mac OS apps that I’ve been accustomed to. Seems a bit strange that Brave has troubles with these swipes, not sure why Brave is a departure from this OS-standard way of navigating.

Btw, I added a video to the original post so the devs can see what I’m talking about (at least what happens on the screen). I’ll post it here, too: https://www.videosprout.com/video?id=9ec4dd27-e2c1-4258-89ac-73a0e57223d4


#5

Ah, I see what you’re saying. I don’t use an Apple Mouse, though. I only use the trackpad on my Macbook Pro. Thanks, anyway!


#6

@oceansurf Sorry for showing you the incorrect screen. It’s listed under more gestures for the trackpad as well.

If this issue persists you should back up your BAT Wallet and uninstall and reinstall.

I have tested the trackpad 2 finger swipe left and right and it is working properly on my (2017 Macbook Pro) mac.

Noticed this when searching open issues.


#7

@v0iD, no problem, I appreciate your help.

I’d rather not change how I navigate from what I’m used to with the two-fingers, though. Brave should really just ensure this works; I can’t be the only Brave user using the built-in Macbook Pro trackpad hehe. I ran into this same issue last year when I was trying Brave for awhile, and I’ve seen other people posting about it. This is definitely not just something unique to me, so I hope Brave can take this seriously and look into it. I have a pretty vanilla Mac and Brave should “just work”.

I did notice that bug you linked to, as well, thanks for sharing it as I do feel like it is related. It is also happening to me, too (Issue: Scrolling makes back button grow on MacBook Pro). With respect, and I do love Brave, but these things just simply shouldn’t be issues with the built-in Macbook Pro trackpad. :wink:


#9

Trolling you? Uh, no, I’m reporting a bug. Don’t be so paranoid, I’m being friendly, polite, and pointing out clear facts to help the devs.

Whether this affects the “majority” or not, this is still a bug, and not unique to me, and should be fixed. It has occurred twice now on two different machines over the course of one year.

Please just let this get to the devs so they can see it and be informed of this issue. I’m only trying to help…


#11

@oceansurf

I posted help for you, it’s up to you to take it or not. The link I posted has info about changing the swipe navigation distance. Check it out as it might assist while the problem is looked at.


#12

That’s really bizarre! I’ve been experiencing the same problems. Today my three/four finger multitouch gestures stopped working altogether! Nothing seemed to resolve the problem (restart, shut down, etc).I did however follow your advice of creating a new user account and logging in to see if multitouch works…low and behold, it worked! I then logged off and signed back into my primary user account and multitouch continued to work! This must be a software issue (I’m guessing). I just deleted the temporary user account and everything seems to be working fine. I set up a Genius Bar appointment for tomorrow - I’ll see if they have any further suggestions.https://www.minimilitia.mobi/ https://www.applock.ooo/ https://www.7zip.vip/


#13

Any devs happen to have the chance to look at this?


#14

cc @LaurenWags to check this one. :slightly_smiling_face:


#15

Have you tried adjusting the Swipe Navigation Distance in about:prefereces on the Advanced page?

I just tried swiping back and forth a bunch of times without issue using 0.23.73.


#16

Hi Lauren,

Thanks for checking into this. This issue is random. Sometimes it works, other times it does not. When it works, swiping works fine for the duration of that tab. When it doesn’t, it is unusable. For example, the video I posted above is when I had recently re-installed Brave and was experiencing this issue in one tab but not another. The Swipe Navigation Distance doesn’t affect it. I adjusted it, but the issue persisted.

I love the Brave browser and what it stands for and I think you guys are doing outstanding work making so much progress so quickly, so I just wanted to help out and post this since I’ve experienced this issue off and on for over a year on different computers. Thanks.


#17

@oceansurf Great way to fix your issue as mentioned in previous posts, is to change the Swipe Navigation Distance. @LaurenWags and I have both mentioned this to fix your trouble.


#18

@v0iD, Thanks, but as I mentioned earlier in this thread, your suggestion did not fix this issue.


#19

@oceansurf It might be something then with “Your” Macbook Pro. As mentioned it has been tested by others and it indeed working. Most found that changing the Swipe Navigation Distance to longer helped. If you are using shorter swipes etc, change maybe to shorter.


#20

Yes, @v0iD, I’ve heard you and your insistence that it is “me” and “my machine” and the Swipe Settings. Could you please step aside and let the devs investigate? I’ve assured you multiple times now that I’ve tried this on multiple computers and the issue persists. Thank you.


#21

It’s not a problem with just @oceansurf’s Macbook. I’m experiencing the exact same issue, and I’ve seen other reports of it too. I’m not sure why you insist on dismissing these concerns. It’s a bug. Whether or not the devs have the time or inclination to fix it is their prerogative, but they should know about it.


#22

Thank you for validating this, @chaseries. Hopefully Brave will take this seriously.


#24

Oh boy, the troll is back. Unfortunately, as we’ve pointed out, that actually doesn’t fix the issue.


#25

Keep it civil please, no name calling.

Unfortunately we have not reproduced this issue yet. That does not mean there is not an issue. However, we can’t fix what we can’t find. There are known issues with current version and macOS trackpad - but they do not seem to quite fit what you’re describing:

https://github.com/brave/browser-laptop/issues/9845
https://github.com/brave/browser-laptop/issues/13468

Chances are these will not be resolved with the current muon version of Brave browser. However, we are currently moving toward the rewrite which includes using Chromium’s native UI (you can read about this here: https://brave.com/development-plans-for-upcoming-release/). If you do not see this problem in Chrome there is a good chance, although no guarantee, that this issue will not occur with the re-written version. I do apologize for the inconvenience this issue causes, but we will not get to resolve all issues with muon-based version of Brave before moving forward.

I will continue to attempt to reproduce this issue, but until we can get reproducible steps we’re at a disadvantage.