Lots of artifacting on Kubuntu Linux

Hi, I’ve just installed linux for the first time and I’m having a lot of artifacting on Brave that wasn’t showing up on Windows 10. I’m not sure if it’s a problem with Kubuntu or Brave, but it isn’t happening on Firefox or Chromium. Here’s the video.

Also, is there any way to enable autoscroll? I can’t seem to find it in the settings. On Window’s it can be enabled by clicking the mouse wheel. It’s super frustrating being forced to use KDE’s slow sensitivity scrolling in long webpages.

same here after the latest brave update just try disabling hardware acceleration in brave just search it in settings and disable it, that should fix it :slight_smile: