Login to Threads and Instagram fail at 2FA step (resulted in account suspension)


Description of the issue: I attempted to login to threads.net via Instagram, and was redirected to the Instagram login page. I tried to log into Instagram via Facebook, and that failed. I tried Instagram via username and password, and reached the 2FA step, but never received the SMS with the code. I clicked the “resend code” link multiple times, with Shields enabled and disabled. After multiple attempts over a short while, my Instagram (and thus Threads) accounts were suspended for violation of TOS, with no details. I was restored a few days later with no details other than “you didn’t actually break TOS, sorry.” I’m timid about doing any further debugging, given what happened.

Exact URL of the website in question: https://threads.net/

Did the issue present with default Shields settings? (yes/no) yes

Does the site function as expected when Shields are turned off? no

Is there a specific Shields configuration that causes the site to break? If so, tell us that configuration. (yes/no): n/a

Does the site work as expected when using Chrome? yes

Brave version (check About Brave): Version 1.62.162 Chromium: 121.0.6167.164