Login/Reg form doesn't work in ios/brave


I don’t want to share my website URL. Can I send it directly to support agent?

Here is short description →

Description of the issue:
When I submit form(login/registration) on my website(react js) - it doesn’t work. Loader spins but the authorization is not happening. It looks like the form is not being submitted.

I tested my sign in/sign up form using other browsers on iOS and Android and Web — and it works good. Also I tested it using Brave on android/web - everything is fine. Issue only on iOS 15.5/Brave

How can this issue be reproduced?

  1. Go to sign in or sign up URL
  2. Enter login/pass
  3. Tap Login/Create and account
  4. Wait…

Expected result: Redirect to «My Profile»

Brave Version( check About Brave): iOS 15.5 / Brave 1.39.1 (

Mobile Device details iPhone 8

Additional Information: Don’t want to share my URL to public


You might read the replies by @fanboynz


Thank you for your response.

  1. With ssl certificate everything is fine.
  2. I just tested with on/off - Settings > Accessibility > Motion feature. It didn’t help me
  3. I tested with/without brave shield. It didn’t help.
  4. I tested on http/https — same issue on both versions.
  5. Everything fine in ios/firefox. Issue only in Brave.

So I still have issue. It looks like it’s not submitting the form. Because when I submit with the wrong data - the error is not shown. And when I enter with the correct credentials, there is no redirect to the profile page.



Test settings

  • Auto-Redirect AMP Pages

  • Private Browsing Only

  • Request Desktop Site

Clear Everything

Something might be blocked; and given your wish for Privacy re your website, then you need help from @fanboynz .

He might show up and ask you to send your Private info to him via Direct Message (DM).

But . . . you found the Solution:

@289wk yes, thank you. I did everything as you asked but it didn’t help.

@fanboynz, need your help!

I found issue. It was on my side.
Checkboxes: Block cookies/Block identification in brave shields settings was active. When I deactivate it - issue was fixed.


1 Like

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.