Login button not appearing on TD Ameritrade while using Brave. New issue

Client Login button on TD Ameritrade appears briefly when I load the page, then disappears and shows a box I cannot click. So I cannot log into my TDA account using Brave Browser.

Issue presented with default Shield settings.

Site does not function on Brave, even with Shields down. Checked with an alternate browser, no issues on the site. So clearly a Brave issue.

I don’t know.

I don’t use Chrome, but it worked as expected when using Mozilla.

Version 1.32.106 Chromium: 96.0.4664.45 (Official Build) (64-bit)

Are you talking about this button?

image

I don’t have an account so I can’t test further, but that button appears and is clickable (after populating the user/pass fields) for me.

What OS?

What settings do you have in brave://adblock ?

It’s similar to that button, though for me it says “Client Login”. It appears briefly when I first load or refresh the page, then it disappears.

OS is Windows 7 (lol)

In brave://adblock there is nothing ticked. I do have some custom filters, but none for tdameritrade.com.

Reboot didn’t work.

Do you have problems with loading other sites?

It’s not clear to me why you would get a ‘Client Login’ button but I get something different. Are you literally on the provided homepage where you see that, or is there a different URL where you see that button? Want to make sure we’re looking at the same page.

The auth section is loaded in an iframe, had no issue here showing the user/pass and login button.

https://invest.ameritrade.com/grid/m/login?cafeVersion=marketing&languagePref=en_US

Does that load? (direct link to the iframe). Does it show in private window mode?

No issues with other sites that I’ve seen.

That was on tdameritrade.com.

Now I’m seeing the boxes to enter the information as I normally would, but in the address bar it says the site is not secure. Attempt to login failed, even though I was sent a text for 2FA and entered it as asked. TDA then took me to a secondary login screen, which I’ve never seen before.

I think I might be facing some sort of security issue, likely due to still being on Windows 7.

That link loads, but it takes me to a login screen I haven’t seen before on TDA.

The address bar also says that link is Not secure.

I have a feeling my issues might be related to still being on Windows 7. Might be time for a new OS.

It is starting to sound like it might be this issue: For users encountering NET::ERR_CERT_DATE_INVALID Error

In which case yes, it is more or less a Windows 7 issue at heart, but there is a workaround there.

I should add, that if your system meets the requirements for Windows 10, you might still be able to get a free upgrade. Worth looking into. Otherwise yeah, a move to Win 10 (or 11) with a new system may be worth it for many reasons if you can afford it.

Yes, definitely seems to be that issue. I had previously found that info in a reddit threat on /r/brave and had been unable to find it again, so thanks for the link. I had tried that previously and it worked. Just did it again, still having the same issues on TDA. So seems like my best option is probably to upgrade.

Just been putting it off for as long as possible.