Locked process, unable to clear w/o rebooting MBA 13"

Description of the issue:
Brave started ok but failed to access anything external (internet). Trying to shut it down failed to close the app. Going into Activity monitor and forcing Quit also failed. Going into terminal and doing ‘kill -9 1234’ also failed.

Steps to Reproduce (add as many as necessary): 1. 2. 3.
See additional info section please.

Actual Result (gifs and screenshots are welcome!):

Expected result:

Reproduces how often:
Only done once. Reluctant to try again as it involves a cleanup cycle.

Operating System and Brave Version(See the About Brave page in the main menu):
MacOS 10.14.5 (18F132)

Additional Information:
This bit is interesting. I have happily used Brave for a week or 2 then decided it would be a good idea to upgrade the SDD with a faster version. When I formatted the new drive I made it encrypted, not sure if that is relevant. Everything else worked as before. Restored from TimeMachine image without issues.

Brave version as offered from Brave download site as of today 27/6/2019.

1 Like

Thanks for reaching out and great write up.
Definitely interesting but I’m not sure what would have caused it. Just to confirm, Brave worked, then you installed a new SSD on your macOS machine – at this point, did you re-install (that is, download and install from the website) Brave, or did you transfer the data from your old HDD to the new SSD?

Hi, Thanks for responding. The Brave version with the issue was the one restored from TimeMachine. All other apps (AFAIK) work fine.

Update. I deleted the Brave app cleared the Trash bin, rebooted. Downloaded Brave again and installed. Now seems to be fine so looks like some quirk of the restore?

Good fast browser that does not hog my limited memory and also blocks much garbage. Thanks!

1 Like