Location not working (Windows 10)

When on google maps my location is reported incorrectly.
https://www.iplocation.net/find-ip-address reports me as being in Scotland when I’m in Essex!

I have the same problem. Works fine in all other browsers on the same marching, including IE, Edge, and Chrome. Only Braver is reporting an old location. I have tried steps from other threads, including clearing cookies and cache. Has anyone successfully solved this?

Is anything happening with this?

@T1M/@JimC,
Seems like an obvious question, but can you confirm that you’re not using a VPN at this time?
Additionally, can you tell me what your Shield settings are set to for maps.google.com (check the Shields panel while on the site)?

No VPN - no difference if Shields are Up or Down.

@JimC @T1M,
Can you please report the results of the following:

  1. Do you get the same behavior if you’re using a fresh profile?
  2. Either way, when you go to maps and it gives the incorrect location, can you please open up the dev tools console and share a screenshot any output here? Menu --> More tools --> Developer tools --> [Console]

Here are the two screengrabs. Chrome is correct, Brave is not


@JimC,
Can you please try testing this with all of your extensions disabled and/or with a fresh profile as suggested earlier?

No change - here is a screenshot with new profile -

What does https://www.gps-coordinates.net/my-location show?

Makes no difference if Shields Up or Down and I’m not using a VPN

Google Maps say my location could not be determined.

“What does https://www.gps-coordinates.net/my-location show?”

My Dev tools console show this.

Can you try Brave beta via https://www.brave.com/beta I just tested in a clean Brave beta profile (and release). @T1M @JimC

Just downloaded Win64 bit - made no changes, no imports, no add-ins. Did not even specify the default browser. Went to map.google.com and the map pulled up in my area (80104 zip code) with NO my location dot. As soon as I hit the location finder button and allowed location access, got the same location error - which is in the 92078 area code where I lived until 2 months ago.

@JimC,
Thank you for testing and we will keep digging into this. However, I do notice that your Menu button is showing an Error message there – can you try going to Menu --> About Brave and see if the updater runs and/or what the error is?

I also tried the beta version and it made no difference.

I think I have resolved this issue - I noticed that Window Cortana was showing weather at the same location as Brave was listing. (my former address) - once I changed my location in my Microsoft Account, both now seem to actually use my location for data.

1 Like

@JimC,
Thank you for checking that. @T1M can you test and see if your system and/or “Cortana” are set accurately?