Linux: new glibc version dependency has removed beta from all centos7/rhel7

Description of the issue:

centos7. brave-browser-beta 0.63.29 now depends on glibc 2.18. centos7 and rhel7 are currently up to only 2.17, ergo the entirety of centos7 and rhel7 has been removed from beta usage. if this new configuration goes main at some point, you will cut off centos7 and rhel7 from brave entirely.

Steps to Reproduce (add as many as necessary): 1. 2. 3.

  1. yum update
  2. thud
  3. headdesk

Actual Result (gifs and screenshots are welcome!):

–> Running transaction check
—> Package brave-browser-beta.x86_64 0:0.62.37-1 will be updated
—> Package brave-browser-beta.x86_64 0:0.63.29-1 will be an update
–> Processing Dependency: for package: brave-browser-beta-0.63.29-1.x86_64
–> Finished Dependency Resolution
Error: Package: brave-browser-beta-0.63.29-1.x86_64 (brave-browser-beta)

Expected result:

normal update.

Reproduces how often:


Brave Version(See the About Brave page in the main menu):

see above.

Reproducible on current live release (yes/no):


Additional Information:

for currently-installed previous release, 0.62.37:

rpm -q --requires brave-browser-beta | grep -i glibc

i’ve had to remove brave-browser-beta in order that other packages be updated. no, i won’t include --skip-broken from now until eternity.


just fabulous, folks.

i filed this report on apr 03. it has gotten literally zero attention. i warned at the time that you were in danger of closing out the entirety of rhel and centos if this glibc dependency was left unaddressed, and propagated to non-beta.

so guess what? today, with 0.62.51-1 installed on up-to-date centos7.6, yum update tells me that it tried to get 0.63.48-1, which fails because of the glibc dependency.

i guess i’m moving back to chrome, because there’s no way i’m running a browser that is actually unable to update.

Error: Package: brave-browser-0.63.48-1.x86_64 (brave-browser-release)


I have a RHEL7 machine too. Looks like I just missed the cutoff by a few days to download brave for it :frowning:

It’s a bummer because I’ve just downloaded Brave on my two windows10 machines and was hoping to use it at work too. But, oh well.

@vanillaknot I’m new to this forum but do you think it would make sense to update the tags to include the main version as well as beta?

1 Like

i don’t see a tag available from tag editing/search that would give new indication of main build along with beta. at best i see an either/or.

what alarms me the most is that it has now been just short of a month, and it appears that no one in brave development has even noticed this report.

what a great way to build confidence among the users, guys. “here’s a whole community of people wanting to improve the program… just don’t count on anybody actually, you know, listening to you.”

Just when I was using Brave as my everyday driver. Now it wants glibc 2.18 and Centos 7 is running 2.17.

Installed using yum with the brave release repo. This sucks. Tried to update to 0.63.55.

—> Package brave-browser.x86_64 0:0.60.45-1 will be updated
—> Package brave-browser.x86_64 0:0.63.55-1 will be an update
–> Processing Dependency: for package: brave-browser-0.63.55-1.x86_64

Hope it gets fixed.

I’d posted about this too. Some support staff said I needed to update the keyring. LOL. I said that the prob is that it was compiled using 2.18. So I guess nothing will happen on this.

Apr 3 to July 8: still there.

A dup ticket is this which has the workaround of installing v0.62.51 for CentOS/RHEL 7 instead of brave-browser-0.66.99-1. Not current but at least there, for what it’s worth.

Under Windows Brave works fine with Crome plugins, works on Android as well. I was excited (and hoping) to use it on CentOS but looks like they’re not geared up for Linux dependency problems, expecting the different vendors to keep everything current.

Looks like installing google-chrome-stable.x86_64 0:75.0.3770.100-1 REQUIRES no dependencies. Wonder why that is? It really IS v75.0.3770.100.

Maybe Brave should consider producing a single “AppImage” for Linux. This “should” have no problems since it includes all of the supporting packages.

I doubt they’ll fix it–they have more important issues to worry about than a few systems which can’t run their software for “not their fault.” I DO hope they consider the AppImage route; that should solve this problem from happening elsewhere (like it will someday.)

PING. Keeping the ticket open. Someone at late July please respond so we can keep the issue alive. Thanks!

This problem is still relevant, is there any solution to this problem? Does someone do it at all?

Not to “me2”, but it’s been nearly two years since the last comment here and over two years since it was opened. It’s apparently impossible to install Brave on RHEL7, then.

I’m running the latest Brave atm on CentOS 7… from Snap.
Might not exactly be a native-experience, but If you don’t mind using snaps:

sudo yum install epel-release
sudo yum install snapd
sudo systemctl enable --now snapd.socket
# log out and back in again, or restart your system, to ensure snap’s paths are updated correctly.
sudo snap install snapd
sudo snap install brave
# log out and back in again to update $PATH and Applications menu