Links not opening on some web pages

Windows 10 Pro x64 build 2004
Version 1.10.97 Chromium: 83.0.4103.116 (Official Build) (64-bit)


On this page the “SEE FULL SPECS” link doesn’t work.

https://www.callofduty.com/ca/en/#
On this page neither the login or sign up work.

These examples work in Chrome, Firefox and Opera.
I like Brave browser. I hope you can get this fixed.
Trevor

What are your Shield settings while on those pages?
e.g. - my settings for Community.

The samsung site/see full specs link is working for me with default settings. Can you check the settings to make sure they’re default and test. If that does not help, could try creating a new test profile and seeing if the issue persists?
Click on the menu icon in the top right corner > create a new profile.

For the call of duty site - can you try reloading the page but with all cookies allowed enabled.

1 Like

Thanks for the reply Aa-ron. I created a new profile and the links that were not working, worked just fine. Next, I decided to “Restore settings to their original defaults”. This actually didn’t change my settings at all. It just disabled the plugins. The non-working links worked. Then I re-enabled my plugins one by one testing the pages in question. All is working now. For plugins right now I have Honey, Coupert and Google Translate. Everything started working when I decided to “Restore settings to their original defaults”. Before this, I tried allowing all cookies and changed all the shield settings. None of that worked. The reset is what fixed it. I was expecting the settings to be changed back to original, but as I said, they remained the same.

Brave browser is awesome by the way and I’m using it as my default browser. I’m really happy it imported everything including browsing history from Firefox which I was previously using.

I guess if links don’t work it’s time for a reset. Thanks for the tips and the reply.

Trevor

Glad you got it working!