Letsencrypt has broken brave and everyother site

Hi, using windows 7 and brave (happens on chrome as well), every site that is using letsencrypt is broken " Your connection is not private

Attackers might be trying to steal your information from …

Every site this happens on is using letsencryt. This very forum, I believe all sub domains cannot even be accessed. " This site can’t be reached

The webpage at https://community.brave.com/ might be temporarily down or it may have moved permanently to a new web address.

ERR_FAILED"

I am using
Version 1.25.72 Chromium: 91.0.4472.101 (Official Build) (64-bit)
and updates are now failing.

I believe it is due to this - https://letsencrypt.org/docs/dst-root-ca-x3-expiration-september-2021/

Looks like my only alternative is to switched to firefox which I am using to post this . Any ideas?

Try this:

Also note the next link which is to another thread that has a workaround.