Leo AI crashes Brave randomly

Description of the issue:
How can this issue be reproduced?

  1. Open a PDF file or website
  2. Open Leo AI (I tested it on llama2:13b)
  3. Ask some questions, go around to other tabs, come back try asking some more questions. It’d crash.

Expected result:
Shouldn’t crash Brave.
Brave Version (check About Brave):
Version 1.61.116 Chromium: 120.0.6099.217 (Official Build) (arm64)

Additional Information:
Using Leo AI seem to crash Brave randomly. I downloaded Brave after a long time and found Leo AI for the first time, but when I tried using it for the first time, it crashed. I reopened it, I tried asking some questions, all goes well. I switch to another tab (create other windows and private windows) and came back to the same tab to ask more questions to Leo AI, and then it crashed.

It crashed a total of 3 times.

Crash 1 at 2:53 AM: d8990e00-46fb-540b-0000-000000000000
Crash 2 at 2:55 AM: d5990e00-46fb-540b-0000-000000000000
Crash 3 at 5:40 AM: 7bcf0e00-46fb-540b-0000-000000000000

1 Like

Latest crash ID: de990000-802f-5e0b-0000-000000000000 (again while using Leo AI) like I described.

I updated to Version 1.61.120 Chromium: 120.0.6099.234 (Official Build) (arm64) on Jan 17, but it is still crashing.

Uploaded Crash Report ID:	353d0100-802f-5e0b-0000-000000000000

I also have this issue:

Brave Version
Version 1.62.162 Chromium: 121.0.6167.164 (Official Build) (x86_64)

How can this issue be reproduced?
It does seem random, but in my experience, it always happens when I attempt to select and copy text results.

So, as a workaround, if I’m using it for a project, I’ll screenshot the results before touching anything else. But it’s been a consistent issue since ever using Leo.

@Mattches and @luke.mulks I know I tagged in one other that was partially related, then I guess is this one as well. Not sure if should merge topics, but as I’m filtering through, wanting to make sure we’re on it. So matches what Aranyaka was saying on Community Call.

@null you still having issues?

@KWEI yours also still ongoing even after update to 1.62.165? And which OS are you using?

@Saoiray Many thanks for the follow-up.

I just tested the scenario I described and discovered, that it only happens when the Leo tab is open amongst many other tabs. If I pull the tab out into a sole window, it seems stable.

Admittedly, I have an embarrassing amount of tabs and windows open. (Btw, appreciate the new tab feature that saves RAM?)

Yes, this is with update 1.62.165. Still crashes, it actually immediately disappears, with no crash report or code.

macOS Ventura 13.6.3
2017 Macbook Pro

This issue is known and should be resolved in the next browser update:

2 Likes

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.