Launching Succeeds But Doesn't Open

windows

#1

Brave has been working for a few months until today.

Something is keeping Brave from opening despite being launched. I know it is launched because when I hover over the task bar icon, it pops up the name of one of the tabs that is supposed to open on launch.

I tried uninstalling and reinstalling without effect.

An interesting phenomenon: While trying to do a screencast of this problem I noticed that OBS Studio’s monitor didn’t show the pop up of the launched browser, even though it showed on the actual display.

OS Windows 7
Brave version unknown because I can’t open it. However, the install file “BraveSetup-x64” has a length of 116,502 KB.


#2

Hi jabowery

I Delete Brave browser and install it.

I use CCleaner at https://www.piriform.com/ccleaner/download and run cleaner both widows and apps and registry cleaner and scan it.

Use I use other browser to install brave browser.


#3

Thanks for the workaround but I’m leery of downloading some software to “clean” my system. Am I going to have go through and configure everything on my Brave installation again such as password manager (or other extensions), bookmarks, etc?

I think I’d prefer to stay away from Brave for awhile until this bug gets fixed so I don’t have to run through a firedrill like this at random intervals.


#4

Hi jabowery

In my experience, this type of problem is virtually always caused by an anti-virus, malware, or other security application. For example, I experienced the same problem with Beckham CPA learning software. AVG Antivirus was preventing it from running. It was very frustrating, because the error messages did NOT say ANYTHING that indicated that this was the cause of the problem. Do you have any security software running such as Norton, Kaspersky, or AVG Antivirus? If so, try disabling them, or whitelisting Brave browser. It may be that an update to their policies caused this new problem.

Were there any Windows updates recently that would have affected security settings? What release/service pack of Windows 7 and Brave are you running? These things can help diagnose the cause of the problem.


#5

I have had this same issue, the only way I can get brave to launch is to install version 15.314 and not update it. I know this is not a good answer, but it is the only way I can get it to run. I started my own thread about this same issue here: Updating Brave issue and according what has been written here it has been reported a lot.


#6

Same issue here. Brave only opens the micro window in the task-bar, but will not populate the full desktop. I’ve tried a few workarounds that I saw online, but to no avail. Surprised nothing else has been resolved in the last week from the date of the previous post. Please help.


#7

WARNING: This “solution” may discard your BAT wallet for your Brave browser, never to be recovered! Money down the rat hole! I say this not knowing where the BAT wallet is stored. (I just transferred about $100 worth of BAT to my browser’s address - which is why I’m now very conscious of this danger.)

I just, today, got Brave working again after deleting the folder at

C:\Users\jabowery\AppData\Roaming\brave

I don’t know exactly what it was in that folder that was blocking, but deleting the whole thing gets Brave running again.

I’m now in the process of setting up Brave again – which is far more laborious than it should be because importing bookmarks from Chrome requires one to go in and drag and arrange them, one by one, onto the bookmark bar. There are other annoyances but none so daunting as the bookmark import.

The only reason I bothered to go through all this is that BAT are now supported and I wanted to start supporting demonetized creators.

In some Brave community messages the folder to be deleted is called the “settings folder” but they don’t say where it is located and one must not be mislead by 1) AppData is a hidden folder, 2) there is another ‘brave’ folder under “AppData” and 3) advice such as "clean your computer with CCleaner (which tries to trap you into paying money as it solves nothing) or 4) manually going through the registry and deleting all references to “brave”.


#8

I should’ve replied sooner, but got caught with a bunch of other stuff… anyways, I tried your solution and it still did not correct the issue for me. I re-downloaded Brave just to be met with the same issue. I did some further searching on the forum and came across this:

Brave, The Browser Itself Won’t Open
QA, Bug Reports, Feedback
I fixed this by pressing shift+alt+space to maximize, then make the window smaller, it will disappear, then press shift+alt+space, the window will now be smaller and you can maximize and minimize, I don’t know why this fixes the bug, but it does. It’s not permanent, you have to do it every time, this bug really needs to be fixed.

This worked for me, however there is still a bug present as this guy mentioned. If i go to minimize the screen the only way to have show back up on the screen is to do the shift-alt-space trick. I hope this helps.

Brave support please fix this annoying bug!


#9

Forwarded here: https://github.com/brave/browser-laptop/issues/12163

https://github.com/brave/browser-laptop/issues/12163


#10