Latest Brave update has stopped things working on places like OpenSea.io

The latest Brave update has stopped sites like OpenSea.io working for me (and probably other sites too).

For example, when typing something into the search bar, I get results but when I click them nothing happens.

I tried closing Brave and re-opening, but no change.

Any thoughts?

That website is working fine for me and I am on the latest update.

Maybe try switching off Hardware Acceleration from the settings, may help.

1 Like

Thanks for checking.

It always worked before, just stopped working after I did the last update.

Something else going on I think. Maybe time for a hard reset.

Keep in mind that if you Hard Reset all your Rewards will be lost, if any…

Also, wait for other people to see into it, maybe they will have better solutions.

1 Like

Check whether the issue persists in a private window without any extensions.

If the issue persist, I suggest clearing your browsing data.

  1. Type brave://settings/clearBrowserData in the address bar.
  2. Click on AdvancedTime rangeAll time.
  3. Select Cookies and other site data, Cached images and files, Site and Shields Settings.

Note: Clearing Site and Shields Settings will reset your global Brave Shields settings, adjust them via brave://shields.

1 Like

Thank you. That fixed it!

Maybe there was some cookie data corruption … :man_shrugging:

1 Like

Ahhh but, one thing it didn’t fix was using MetaMask on OpenSea. Still works on Chrome browser.

Any thoughts?

There is an open Github report regarding MetaMask, hopefully developers will fix the issue soon as a lot of people are currently affected.

Meanwhile, in another Community thread, @Luckys shared a workaround that worked for a few users, you might give it a try if you like.

1 Like

Right, thank you.

They must have just introduced that in the latest few versions as used to work before I upgraded (on Mac).

Cheers

1 Like