Latest Brave Update - GChat blocked by 3rd party Cookie Control


#1

Hey, I don’t know where to post this but thought someone ought to be aware.

tl;dr Sending gchats is blocked by the 3rd party cookie slider. This was NOT a problem until the most recent upgrade.

I don’t if gchat is handled by 3rd party cookies, but I do know that it isn’t blocked by any other browsers’ block 3rd party cookies extension.

It’s not totally gone - you can still see the contacts list, see new messages that are coming in, and it still lets you type - for all ostensible purposes, it isn’t blocked. However, any outgoing message you write never actually sends. See screenshot.

I think this is a bug because gchat is a normal use of a browser, and as said, in other browsers I have extensions to block 3rd party cookies and none of them have ever stopped me from sending gchats.

Sorry, I had more screenshots but it will only let me upload one. To be clear, the slider is in the brave icon dropdown, under 'advanced controls -> Cookie Control." Setting it to “Allow all cookies” lets gchat work; setting it to “Block 3rd party cookies” (obviously preferable) does not.

I’m on a mac, Sierra 10.12.5. Brave version info:

Brave: 0.18.29
rev: 85f059d83b8861b3a7e127c42b2fe9d574be5810
Muon: 4.3.16
libchromiumcontent: 60.0.3112.113
V8: 6.0.286.56
Node.js: 7.9.0
Update Channel: dev
OS Platform: macOS
OS Release: 16.6.0
OS Architecture: x64


Google Hangouts Bug - "Message not Delivered"
#2

Thanks for reporting this.

We have opened the following issue in github to resolve, which you can track progress in. I’ll add your report to that issue as well.

Github issue: https://github.com/brave/browser-laptop/issues/10875

I’m going to close this item, since we are already working on resolving in queue.

Thanks,
Luke


#3