Lastpass on windows doesn't work

windows

#1

Since Brave seems to be an electron app which doesn’t work well as yet in KDE Plasma on Linux (bug with global menus, fix is in upstream, waiting for update) I am not installing it on Linux. But I wanted to give it a try on windows as I’m searching for quick and resources friendly browser (I like Vivaldi and chrome and I use them for some online apps, but I still need main system browser: firefox borked out lately and is too heavy for my work windows computer - high CPU usage on idle for me, opera is a bit strange, doesn’t have home buton and is not convienient, edge is also a bit slow and unfriendly. I’m running out of options…

Unfortunatelly, Lastpass doesn’t work on windows in brave. I enabled it as extension, set it as main password manager on security tab, restarted the browser and… nothing. No lastpass icon, no lastpass options anywhere. When I click on settings it opens error page.

Without lastpass, a browser is unusable to me.


#2

Hi @michaldybczak

Can you please provide additional information such as your Windows version, Brave version, and LastPass version (available on the extensions page)?

Can you post a screenshot of what you mean by:

Thanks,
Lauren


#3

Windows 10 with latest updates.
Brave 0.18.23
rev 36ae2ec
Muon 4.3.10
libchromiumcontent 60.0.3112.90
V8 6.0.286.52
Node.js 7.9.0
Update Channel dev
OS Platform Microsoft Windows
OS Release 10.0.15063
OS Architecture x64

Today is even worse, extension page is empty:


#4

Brave starts very, very slowly, loads google page also in snail speed and behaves strangly (after loading page is either darkened or empty, dependent on where is my cursor and only after clicking it goes back to normal).

I’m not sure, but I think that all might be related to installation. It never asked me for admin mode which is strange.

After restart it’s a bit better. Since I can post only one image per post, here it is:

Extension page that loads finally correctly:


#5

I start to feel that this is very unfriendly community. Someone was out of their mind setting limits on this forum.

I came here to resolve a problem, because I though the browser deserves a try. I was asked for screens. I wanted to provide them but system informed me I cannot post multiple screens in one post… Weird, usually multiple posts are discouraged but you forced my hand so I posted first post and… it was automatically flagged and became invisible. So basically I cannot post a screen. Thanks for “welcoming” and “sane” forum settings.

Brave is so screwed and forum unwelcoming that maybe I just better forget about it :frowning:


#6

@michaldybczak You posts have been unflagged. Sorry for the inconvenience.


#7

OK. I haven’t posted everything, so here is the screen with the error page which opens after clicking on configuration of lastpass on security page:

EDIT: Forum won’t let me to post the link to the screenshot (placed in dropbox like the ones above). Maybe when I put it in some brackets?

[https://www.dropbox.com/s/yn0csfb0b0wkx3h/Zrzut%20ekranu%202017-08-23%2008.52.59.png?dl=0]

EDIT2: I reinstalled brave and see no difference. No ask for admin mode and lastpass still doesn’t work.

EDIT3: System restart doesn’t make any difference either.


#8

@michaldybczak Could you try the following steps and let us know if it works

  1. Disable Lastpass in Brave and Quit the browser
  2. Open %appdata%/brave
  3. Open Extensions folder in it
  4. Rename folder hdokiejnpimakedhajhdlcegeplioahd to some other name. This removes the previously installed Lastpass extension.
  5. Restart the browser and enable Lastpass and check if it works

#9

I did all the steps but unfortunately it didn’t help. Once I activated lastpass again (slider), folder hdokiejnpimakedhajhdlcegeplioahd showed again (previous one was renamed to old-lastpass) and there is no lastpass icon, lastpass preferences result in error page.

Another thing is, loading time of Brave is extremely long. Chrome with 5 tabs and complicated account online service starts with 20s (old computer, that is why it’s so long) while Brave opens with 1 tab with google in 90s… But maybe that’s a thing for another topic, although I’m unsure how that can be debugged.


#10

Regarding load time we have an issue logged for that and the fix is being worked on. You can track it here

Could you try backing up your brave profile and then check once. You can rename the brave folder to brave_old in %appdata% and then launch the browser.

I am using a Windows 10 with same version but I do not see any issue with Lastpass.


#11

Renamed it to brave-old, launched browser, set lastpass, restarted brave… and the same :(.

I reinstalled brave today and also see no difference.

It seems I can’t get it to work normally by any means :frowning:

I use chrome, firefox-nightly, edge, vivaldi and opera and they all work, except firefox (high CPU usage in idle state, even in safe mode, in normal version and also in nightly after few days, refreshing installation isn’t helping - also specific issue to my computer). My work computer seems to have some issues with firefox and brave…


#12

That’s odd. Did Lastpass work before upgrade to 0.18.23? Or was it a new installation done for 0.18.23?


#13

This is completely new installation of brave browser. But I do have lastpass on other browsers and am unsure if I added it separately to each of them or installed via general installer. Maybe mix of both.


#14

Could you try uninstalling the Windows installer and check with a clean install of Brave?


#15

I didn’t find the lastpass installer, so maybe I was wrong. Anyway, I uninstalled brave with revo uninstaller, installed it again and the same issue. Maybe install file is corrupted? Will download it again and try again to install it.

EDIT: Installed it again from new install file and nothing, still the same. I’m out of ideas. It seems that it just won’t work on this system.


#16

Same issue for me.
laspass & pdf viewed are totally absent of the install


#17

@michaldybczak @pasme I have logged an issue for this to be investigated. Please track the issue here

Will be closing the thread. Please open a new thread if you find any other issue


#18

#19