Last 2 Android updates have wiped all homescreen bookmarks


#1

I just updated three devices, and all 50ish of my home screen bookmarks have gone on all devices, I literally watched then disappear in about 2 seconds.

This is the second time this week Brave on Android has updated and wiped all my bookmarks.
Sometimes, when re-creating them, I’ll add to home screen and upon clicking it it will say ‘App not installed’ - so I have to re-create the bookmark yet again.

Any chance of fixing over with future updates?


#2

Hi @dancedar,

Thanks for reporting!
Will cc-ing @Serg @LaurenWags or @samartnik for visibility.


#3

@dancedar What is your current Brave version?

Also, what devices and OS did you see the issue on?

Thanks,
Lauren


#4

1.0.33, so this version and the one before it wiped bookmarks.

On Android Nexus 7 2013 Lineage OS 7.1.2 and Nexus 5X 8.0.0 both using Nova launcher, but tried stock launcher and same happened.


#5

I have had a similar problem with the Android version (Brave v1.0.33 Chromium 61.0.3163.98) on my Huawei P8 Lite 2017 phone running Android 7.0.0 Nougat.

When a bookmark is created on the home screen, you can give it a name or accept the default name, and Brave selects an icon (either the favicon of the site or an icon generated automatically with the initial letter of the site name and the site dominent colour). That’s perfect. I have 20 shortcuts created that way on my start screen.

Now, the bug: When Brave is updated (from the play store), ALL shortcuts are replaced with shortcuts simply named Brave and with the icon of the Brave browser! It is therefore impossible to recognize them, since they have lost their name, icon and colour. However, they do not disappear completely. They are just modified. The link within the shortcut is still correct, and launching the bookmark opens the bookmarked site correctly. It is just a pain to locate the right bookmark without their correct names and icons.

It seems that it’s “only” a cosmetic bug, but it is extremely frustrating and serious, as the user must recreate all shortcuts manually, one at a time, each time Brave is updated, just to make them recognizable again. The bookmarks stored in the Brave browser itself are not affected by the bug.

It’s the 2nd time that Brave is updated and the bug occurs since I have adopted Brave, and I don’t want to recreate all shortcuts a third time, so I would appreciate if that bug could be fixed for the next update. Thanks in advance to the team.


#6

I forgot to say that I use the stock launcher. Most of the shortcuts are stored in drawers on the home screen.


#7

If I restore a Nova backup with shortcuts present the disappear after a few seconds - it’s like the associated action has disappeared or the deep link has changed and this isn’t registered, thus invalid, this wiped I guess.


#8

@dancedar and @r0lZ -

Researching this issue. Just wanted to know, are you both getting your updates from the Google Play Store or are you downloading updates from our github repo?

Thanks,
Lauren


#9

Google Play Store for me


#10

Play store for me too.


#11

@dancedar and @r0lZ

We just put out another update. I tested updating from 1.0.33 to the new version (1.0.35) and did not lose my home screen bookmarks. If either of you experience this when updating to the new version please let me know. If so, I’ll need to gather more data.

Thanks,
Lauren


#12

Yes, the problem occurred again.

Before the last Brave update, I did a restore of the system settings (but not a full factory reset) for another reason but that was obviously not sufficient to correct the problem. I guess it is caused by an incompatibility of the Brave bookmarks with the Huawei stock launcher.


#13

@r0lZ another question for you - do you see the home screen bookmarks disappear right away after updating, or does it take some time?

Lauren


#14

Happened to me updating to x35 I recall.
My bookmarks disappear in seconds after updating


#15

Thanks for the info @dancedar.

I logged an issue and will be continuing to investigate. If you have any other information that you think may help, please let me know.

I am curious, have you encountered this issue with any other browsers, such as Chrome?

Thanks,
Lauren


#16

Honestly, I haven’t paid attention to the shortcuts for a while. It’s when I have noticed that they have been changed again that I have verified at Google Play that Brave has been updated recently. That was the case, as I suspected.

Not sure if that matters, but the shortcuts were in a folder, and not directly on the home screen. But I suppose that the same thing happens when they are directly on the home screen. I haven’t tested that though.

Chrome was disabled, so I have enabled it, then I have created two shortcuts on the home screen: one with Chrome and one with Brave. Then I have updated Chrome with Google Play. No problem with the shortcuts. Finally, I have disabled Chrome again, and the shortcut created with Chrome has been removed (as it should). The other shortcut is still correct.

I can’t test again the behaviour of the shortcuts with Brave, as I have now the latest version, but if you want more tests, give me a link to download an older version, and I will be happy to help.

BTW, I don’t create shortcuts on the home screen any more. They are handy, as using them from the favourites folder in Brave requires more clicks, but not absolutely necessary, and I am tired of having to recreate them after each update. So, if you want more feedback, please tell me here when an update will be available. I will create a shortcut before updating Brave, just to verify…


#17

Just updated Brave to v1.0.37, and I have added a shortcut on the home screen just before the update, to check if the problem persists. There was also a shortcut (created earlier) in a folder on the home screen. After the update, the new shortcut is still present, with its original icon and the correct name. But the shortcut in the folder has again been changed, so it appears that the bug is still not fixed. But it seems that the shortcuts are affected ONLY when they are in a folder, at least for me and my Huawei P8 2017. (Or is it because the shortcut has been created long before the update? I don’t know, but I don’t think so.)

I hope this will help you identify the problem.


#18

Thanks @r0lZ - I tried again with the latest version (1.0.37) myself and I am still unable to reproduce. I did link your last comment with additional information to the issue in the hopes that it will assist development in finding the cause of this issue.

Lauren


#19

This topic was automatically closed 60 days after the last reply. New replies are no longer allowed.