Language: English is my only language. When in Mexico, all my search results are in Spanish


Description of the issue:
I am Canadian, and only speak English.
When I bring my laptop to Mexico all my search results on the brave search, using brave browser, are shown to me in Spanish. Even though I have my language settings set to. English UK, English USA, English.

  • I did have the ‘use brave translate’ turned on, because I thought it would translate any Spanish sites I visit, for example. Aeormexico.com to english.
    However this is not the case.

It seems that all my results are not being shown to me in my default language of English.

Seems the browser is only looking at my IP address of what country I’m in, and is trying to help me by translating all websites to spanish. At least all the search terms are shown in spanish.

Specifically: I searched for a medical term in brave search/browser: “Escherichia coli”. I wanted to learn about this. In English.

The top 2 page search results:

![:globe_with_meridians:|16x16]
Infecciones por Escherichia coli: MedlinePlus en españolmedlineplus.gov › página principal › temas de salud

August 3, 2021 - Infecciones por E. coli son causadas por una bacteria. Puede hacer que se sienta enfermo. Conozca los síntomas de E. coli, tratamientos, y más.

AND


![:globe_with_meridians:|16x16]
E. coli - Síntomas y causas - Mayo Clinicmayoclinic.org› es-es › diseases-conditions › e-coli › symptoms-causes › syc-20372058

October 1, 2022 - La mayoría de las cepas de Escherichia coli son inofensivas, pero algunas pueden causar problemas graves. Conoce los síntomas y el tratamiento de esta enfermedad frecuente transmitida por alimentos.

AS YOU CAN SEE - these results are pulling from the ‘spanish’ pages provided by the websites found, rather than the ‘english’ pages provided by the same site.

We know that mayoclinic has pages in multiple languages, for example. I need my results to come from their pages of my default language.

How can this issue be reproduced?

  1. I’m not sure how you’d reproduce this, because you are not me? You could try it on your own browser, I guess.

Expected result:
I would think, that by setting my default language to all three available English languages, that no matter where I am in the world, search results and webpages would be shown to me in my default language.

I don’t understand why the websites ‘spanish’ pages are shown to me. Other then they are ‘reading’ my IP addresses.

I don’t think I should have to find a VPN. I’m just traveling, as an English person, I need my default language to be what provides my search results, not my country of location.

Brave Version( check About Brave):

Version 1.47.171 Chromium: 109.0.5414.87 (Official Build) (64-bit)

Additional Information:

Thank you,

Seems this topic has a similar issue?

Might be. If you didn’t change region on the Search, then it would make sense to work as it did. By default it’s trying to find results that not only match your search details, but also your location. If your results were set for local, which would be Mexico, then most of the results from Mexico would be in Spanish. Hence why you received the options you did.

Just by me changing region as I mentioned in my post you linked to, it influences results as you see below:

United States

Mexico

I just moved your topic over to Search Support. I was debating Search Support or Search Feedback. But since the issue is with Brave Search and not with the browser itself, wanted to get it to the right category so hopefully the right people can see what you’re mentioning.

Thank you

I really appreciate your assistance with getting my request moved to the proper area.