Keyring login at startup and motion sensor problem disconnecting internet

I am constantly getting keyring login when I first run the browser.

Also, after about 10 minutes of use I get a motion sensor error and my internet connection completely goes. I have to restart my computer for internet to come back on.

It works perfectly fine in Firefox and Chromium.

No response? I am using Chromium now and I am not being disconnected.

keyring

This is what I get when I use your stuff.

Is it Ubuntu with auto login enabled by any chance?

Found a few articles, maybe will help. Not clear to me at this point what the relationship is between the keyring and the browser (any browser) in this environment but it looks like it could happen with others as well, depending on the order and manner in which things were configured.

Thanks for the reply. I am not stating they are related. I am listing two problems I am encountering specific to ONLY the Brave browser. No other browser (Opera, Chromium, Firefox, Midori, etc…) have this keyring issue and they don’t disconnect me from the internet after 10 minutes of usage forcing me to restart my computer. As soon as I stopped using the Brave browser, I no longer encountered these two issues.

Yeah, I get all that. My statement about the “the relationship is between the keyring and the browser” isn’t a criticism of your post, it’s just pointing out the fact that I don’t understand, yet, why the other two browsers would NOT have this problem, but it’s likely that they were integrated together somehow at some point.

So to move forward, can you please answer the earlier questions, and also make sure you have gone thru those articles if they apply?

I am not sure of the exact questions you have. I went to the articles, nothing removed the password window when starting it up.

Another frustrating aspect to this is that I have to shut the computer down and restart each time to test if the Brave browser will launch the password window again. So I 1) edit something in the password area 2) reboot 3) relaunch the browser 4) see the window 5) edit something else in the password area and repeat from step 2.

I am not seeing much benefit in keeping the Brave browser. I would rather download and use a browser that doesn’t launch this keyring login window out of the box. Or, make something in that window that has a checkbox “Don’t show again”.

The time it is taking me to find a solution could be used doing something else on the blue Chromium browser, Opera browser, and Firefox browser.

I have had to remove the Brave browser, it is hijacking my links when I click them and then I end up in an endless waiting cycle. I’ll revisit the Brave browser when it is more user friendly. I have college courses to get ready for and work to do. I can’t spend all my time trying to find out why Chromium, Firefox, Opera, Midori, etc… work fine but Brave doesn’t. If anyone else is having a problem, please visit this site: https://askubuntu.com/questions/1217043/how-do-i-remove-brave-completely

OK, whatever works for you is fine.

If you ever come back around to it and have issues again, you might want to start off by providing more information and answering helpers’ questions to move things along. For instance, you didn’t even let me know whether or not you were running Ubuntu, nor whether you had Auto login enabled. From your last post I can deduce that it is indeed Ubuntu; but too little, too late it seems.

Take care!

1 Like

Folks, I don’t think this is the OP’s issue but I wanted to log something here as it is related and other people may come across this thread if they hit the Keyring issue.

Funny enough, something similar just happened to me with Brave on a Fedora device. (I didn’t lose Internet or anything like that; I just got prompted about an unlocked keyring.)

In my case it was because I started using biometrics (fingerprint) to unlock the device. Apparently, this does not unlock the GNOME Keyring. Maybe there’s a setting for it, haven’t looked yet.

But anyway, if I sign into the laptop with Password, it does unlock and I can access stored passwords without any further prompting. If I sign in using biometrics, the Keyring does NOT unlock, and when I open Brave, I get prompted.

I already uninstalled Chrome and I’m not putting it back, but I can test some more later with Chromium and Firefox and report back. I have to assume the behavior will be the same because the Keyring behavior is observable before opening any apps at all, it’s doubtful that any other app would be able to magically unlock it and may even be concerning if so.

Yeah, so that’s it. And Chromium does the same thing. Looks like this occurs if Seahorse is installed.

Firefox doesn’t cause the prompt, but there IS a storage entry in the Keyring (Seahorse app) for it, so presumably it could require a keyring unlock at some point, otherwise it wouldn’t have been able to store and access anything in it.

Found this link as well: https://support.google.com/chrome/thread/3452787/how-do-i-remove-the-keyring-login-prompt-using-ubuntu-16-04?hl=en

Seems there’s a workaround some distros use for Chrom* browsers, adding some CLI options to use ‘–password-store=basic’ to avoid this. Might be something the Brave Linux package maintainers would want to look at? In one sense it’s a degradation, but it would also address a lot of user issues and questions.

If @tigerprowlusa is still paying attention to this thread, I think at least the first of your two problems is solvable using the above info. Your 2nd problem I have no idea, but one thing at a time.

But at the very least we end up with a better understanding of how this works on Linux platforms.

@Mattches, maybe something to get in front of the Linux package maintainers?

@JimB1,
When you are using the browser and then have to restart, is Brave saying that it crashed?

No, I don’t actually have those additional problems the OP was dealing with – I only ran into the auth prompt.

If Seahorse is locked, I get the auth prompt when Brave starts up, but if I decline to unlock it a few times the prompting will stop and the browser loads.

At that point Brave seems to still work just fine, although my Sync settings are effectively disabled. They all appear to be turned off, and if I change them, they just get turned back off again if I close and re-open Settings. I’m guessing the Sync chain key is stored in Seahorse somehow and is inaccessible when it’s locked, but the browser doesn’t have a way of providing feedback here to tell me there’s an issue.

If I close Brave, unlock Seahorse, and then open Brave again – no prompting, and, my Sync settings are back to normal. Same thing if I log out, but log back in using a password, since Seahorse will get unlocked.

I haven’t seen any crashes or any ‘Internet not working’ stuff. Whatever is going on there, I suspect is a separate issue specific to the OP.

@JimB1,
Thank you for the information. I actually intended to tag OP in my first reply but I do appreciate the response :sweat_smile:

1 Like