KeePass extensions doesn't work

After updating Windows 10 with the latest feature update the various KeePass extensions (e.g. ChromeKeePass) can’t connect to the keepasshttp-listener (plugin to KeePass). Before the update everything worked just fine. Strange thing is that the extensions does work in Chrome. The extensions tries to connect to “localhost:19455”.

V1.20.110

2 Likes

Same constellation with Brave V1.21.73

1 Like

I have the same issue. Weirdly enough if you go to the KeePass Helper Options page for the extension, it shows that the connection “looks good”.

image

1 Like

Got the solution from the plugin author;

Localhost is being blocked by the adblocker.

In Brave go to brave://adblock and in the textarea at the bottom, enter this line:

@@||localhost^

2 Likes

Thanks, but unfortunately it din’t help for Brave V1.21.73

I only added @@localhost and that works.
image

Didn’t work for me… :cry:
2021-03-05 13_03_26-Window

Thanks! It works for me.

Weird. What plugin do you use?
I use the KeePass Helper extension and it works with that.

It requires the KeePassHttp extension.

OK.
I’m using the Kee extension in Brave in combination with KeePasssRPC plugin in KeePass (from Kee Vault Ltd)
I’ll look into KeePass Helper.

I use the KeePassHttp plugin in KeePass and any of the extensions that uses that. Right now I am preferring ChromeKeePass.

1 Like

Thanks, It’s working with the KeyPassHttp plugin!

1 Like

same problem with the last windows 10 update…19042.844

Version 1.21.73 Chromium: 89.0.4389.72 (Build officiel) (64 bits)
kp 2.47
kprpc 1.14
kp chrome extension 3.7.8

no problem with FF and Chrome

Ok it’s work with Brave and KeePassHttp.plgx : https://github.com/pfn/keepasshttp/blob/master/KeePassHttp.plgx

1 Like

Perfect! For now the KeePassRPC plugin is broken.

1 Like

I have the same problem. After updating Brave the Kee extension no longer connects to KeePass. I’ve tried the suggestions above but without success.

I have had to install KeePassHelper in order to get some functionality back.

The issue seems to be solved with the latest update (v 1.21.74) of Brave. Woohoo!

Not working: Version 1.21.73 Chromium: 89.0.4389.72 (Official Build) (64-bit)

Working: Version 1.21.74 Chromium: 89.0.4389.72 (Official Build) (64-bit)

Thanks for the info! Works for me too.

Just a heads up. An update removed the filter from the adblock causing ChromeKeyPass to fail. Adding @@localhost again fixed it, again.