Keep losing address bar

Can you add Samsung Galaxy S20 (SM-G980F/DS) to the list of the devices affected.
Do you need the OS build number?

On it — thank you for sharing

I’m experiencing the same issue on my Pixel 4XL.

A quick work-around…

Click on the three dots on the bottom right. Click on the Share icon. The browser will bring up a caption window on the bottom with the option to copy the link to the page you’re on.

I started using Chrome again and thought…f**k this, there has to be a hack to get me by. Sure enough.

dont know if it is related, but about:config doesnt seem to work anymore, says cant reach page.

I’m seeing a slightly different issue. For me the top URL bar is completely blank and can’t be tapped.

Device: Pixel 6 Pro
Android version: 12
Build number: SP2A.220505.002
Brave version: 1.38.109

@runswithjedi ,

Please edit your reply, to include

  • device information
  • Brave Browser version numbers

I edited my reply with the info.

1 Like

@cobrax2 ,

See brave://chrome-urls/#internals in a Brave Browser > New Window.

i used the flags one to default the grid table tabs and now everything seems to wotk. so this is the setting that screws everything up!

1 Like

Doesn’t work for me unfortunately

However, hitting Reset in brave://flags has solved the problem for me - so something else I set may also cause this, but unfortunately it’s too late for me to work out what that was


Works for me. I could have sworn the only setting i had was trying to disable tab groups, but i tried making that setting again and its still working now.

Same here. I side-loaded the latest version, 1.38.111, and still had the issue so I went to brave://flags and did reset all.

I had disabled everything for tab groups and tab grid view that I could find so that’s probably what was affecting it. I really want the old stacked tabs back!

That was the ticket for me too on a Galaxy S22. I had 2 Experimental flags changed - Tab Grid Layout, and Grid tab switcher for tablets. Changing the first one back to default did not fix it after a relaunch (it may be both settings affected it). Changing the second one back did seem to fix it. I personally also preferred the stacked tabs vs. the grid and don’t use tab groups, so that’s why I had those changed. That being said, stacked tabs haven’t worked for me in a few versions.


Ditto on resetting all the flags fixing the issue. I tried setting the tab-grid-related ones back to disabled, but the problem did not return for some reason.

Also ditto on an all-consuming hatred of tab grid that burns with the heat of a thousand suns. Why can’t I have stacked tabs anymore? It takes forever to scroll through the grid and find something, which is why I had tried (in vain) to get rid of it.


Yeah I have this issue as well. Its been really annoying since the last update having to restart brave everytime I switch tabs.

Only temporary respite I found was in swiping to change tabs to avoid it temporarily.

Phone: Asus Zenfone max pro M2
Android version: 9
Brave version: 1.38.109

PS: Bring back Stacked Tab view. It’s literally the very reason I quit Chrome for Brave. That and Chrome Dev’s thinking it was a smart idea to force permanent Tab groups…

Same problem here. Brave version 1.38.109. Xiaomi Mi A1, LineageOS 18.1 (Android 11), updated 3/5/22.

Can everyone here confirm that setting the Tab grid layout and/or the Grid tab switcher flag (in brave://flags) to Default value fixes the issue?

You know, the fact that most of the problems people had here had a specfic flag that is related to the removed tab system is kinda worrying.

I mean, even then before all this, I had gotten the same problem, and I just usually lock and unlock my phone. I haven’t used the latest version to check if it works by setting said flags though, so…

I guess that’s one more to the “please return stacked tabs group” request.

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.