It's BACK - Processing Request Hang

Cannot capture the PROCESSING REQUEST notice but it is BACK after 2 new releases / it is the notice that appears in the bottom right or left corner that displays the status of the page loading (Waiting for Bing.com / waiting for cache / displays the HTTPS address - that area). On other pages it shows the PROCESSING REQUEST for a millisecond and then proceeds / but on Facebook it will HANG at the PROCESSING REQUEST status until I either re-click the link or go to another page and then back to Facebook.
Went away but has returned with the latest release of the Brave browser. HELP.

Hope that this explains it better.

Description of the issue:

Steps to Reproduce (add as many as necessary): 1. 2. 3.

Actual Result (gifs and screenshots are welcome!):

Expected result:

Reproduces how often:

Operating System and Brave Version(See the About Brave page in the main menu):

Additional Information:

2 Likes

I was having the same issue and thanks to /u/Byggpemis on reddit I’ve figured it out. My detailed post is here:

The TL:DR is that if a book mark has HTTP instead of HTTPS and an ad/tracking blocking extension was running I’d get “Processing Request”. Disabling the ad/tracking blocking extension would allow the page to load.

Once I changed my bookmarks to HTTPS the issue went away, pages would load with the extensions enabled.

I tried disabling “Upgrade connections to HTTPS” in settings but it made no difference.

I’m going to post this as a new topic using the bug reporting template.

2 Likes

Score one for REMO. In reviewing my Bookmarks I saw that Facebook and EBAY were both shown as HTTP so changed them to HTTPS and NO PROBLEM.

Thank you Remo.

I am seeing the same problem when I type URLs into the address bar (e.g. bbc.com/news). I unchecked the Upgrade connections to HTTPS" option in Settings, and that seems to have fixed it for me. Thanks for the help. This was driving me nuts. :slight_smile:

Same problem since latest stable upgrade. Open a new tab, processing request… Open another tab, type the same address, same thing. Open the same website but adding https:// in front and it opens.
You can try with ghacks.net and https://ghacks.net
I don’t want to disable “Upgrade connections to Https” so I’m switching browser in the meantime. Hoping it’s a fix someone noticed.

This has been bothering me for weeks now. Seems that once disable HTTPS upgrades in the Brave Shield, stuff instantly starts working again. Manually replacing http:// with https:// does nothing for me, however.

This has been broken for me for weeks too, driving me crazy. Thanks for the tip to disable https upgrades! You can also usually get it to work by just clicking in the address bar and pressing enter again when its frozen, that’s what I’ve been doing.

Btw… how has this not been fixed yet? Guess brave developers don’t use their own browser.

Possible fix: I changed my default settings on my router / modem for Set the DNS servers allocated with DHCP requests. from the default servers (Centurylink) to those used by CLOUDFLARE which are: 1.1.1.1 and 1.0.0.1

Not very much Processing Request hanging at all / very fast page loading.

Worth a try? My vote is YES.