It's "Aw, snap" time


For the last few days I’ve been using Brave normally to watch some YouTube videos. Had several other tabs opened like eBay, Amazon, etc. After signing in to eBay, Gmail would start returning the “Aw snap” thing. Deleted cookies and Gmail went back to normal …until I signed in to eBay again (had to delete cookies repeatedly just to open Gmail). I jokingly told myself this was probably some sort of conspiracy activity from the online ad dependent, allmighty Google.

Then, just yesterday, Brave suddenly became inoperable. It started to constantly show the dreaded “Aw, snap” page for everything I tried to open… not only websites but internal stuff like browser options too. I started noticing the error icon even on inactive tabs that had not been opened for a while. No updating or system changes had been performed on my PC, just normal browsing, until the problem literally appeared from nowhere. Tried clearing all browser data, uninstalling and reinstalling Brave, restarting Windows etc. to no luck.

I’ve made sure this is not caused by a connection problem on my end. Firefox and IEexplorer 11 and all Internet apps work just fine. Since I’ve had other unsolved issues like tabs not restoring after system crash/ restart and being unable to open a specific torrent app from Brave, and since other users have previously reported the aforementioned problem without ever finding a fix, after many attempts I’ve decided Brave is just not for me and uninstalled it.

Still I’m bringing this issue to your attention hoping that my experience might help your team get it sorted out some day. I honestly could not care any less about rewards and the like, but as a simple browser Brave seems too unreliable, at least for the time being. Anyway, I wish you the best of luck with your project,


Description of the issue:

**Steps to Reproduce (add as many as necessary): 1. Open any tab in Brave browser
Actual Result (gifs and screenshots are welcome!): “Aw, snap” error

Expected result: Webpage opened

Reproduces how often: every time

Operating System and Brave Version(See the About Brave page in the main menu): Windows 8.1 Pro

Additional Information: Problem appeared abruptly after no changes done to the system

Hi @Resumil,

Thank you for taking the time to make this post! I’ve just chatted with a few folks on the team and it looks like this issue has been resolved in the most up to date build.

Are you still around to give it another shot?

Let us know if there’s anything else that we can help to answer.

This topic was automatically closed after 30 days. New replies are no longer allowed.