Issues with LastPass and website performance

performance
windows

#1

Hi, I just installed Brave on my Win 8.1 pro and I’m having some problems. I have tested these issues on Explorer and they are non-existent there.

  1. The browser takes literally about 10 seconds to load, I do have 4 pages pinned but I assumed if it did lag a bit, it would be after it launched as the 4 pages need time to load. Do pinned pages affect the time Bravo takes to launch initially? My laptop isn’t slow by any means and my connection is very fast.

  2. On HGTV and DIYnetwork.com, I cannot log in to my account but on other sites, I can.

  3. I cannot submit basic forms on these sites. The links on the pages work fine but when it comes to me submitting info for a survey type deal, it will not respond at all, no loading symbols or anything. It’s like I didn’t click anything at all.

  4. I am also not able to access my LastPass credentials by clicking the logo in the username field like I was able to on Chrome which was uninstalled yesterday. Cricketwireless.com also has the same issue.

  5. I do not see the logo to click to select the identity I wish to log in with and LastPass also does not auto-fill my login like Chrome did.

All these issues don’t occur on Explorer except for #4 since I don’t have LP extension installed on it since it was my backup browser to Chrome which I no longer have but on Chrome, all these sites auto filled my login info and allowed me to choose a different ID by clicking the LP logo in the User ID field. The same goes for adding an account to GMail or logging in.

I have checked the settings and have tried restarting the browser and computer to no avail. Please advise on what I should do? These are all reputable sites that I’m having issues with and since they have worked flawlessly on other browsers, I’m thinking it is not due to a user error.

edit: So I just shut down my comp and turned it back on and all the issues are resolved. :grinning:
Loading take about 2 seconds with 4 pinned pages, LP is auto logging and showing other aliases for selection on Cricket and GMail. I had installed some Windows updates last session, so that may have slowed down my system? IDK what was going on but it wasn’t like this upon my first use last night which is why I uninstalled Chrome ASA I liked the initial speed of Bravo and features.

One question about the bookmark menu, can I add more than 10 or is that the limit?

Love the browser, keep up the great work!


#2

Hi @DUTCH81,

Thanks for reporting and glad that your issue is solved (I guess the all 5 issues above solved right?). Shut down computer sometimes always do magic. :smiley:

For startup time, there’s an open issue to improve it. But I can say, Brave trying to improve it in every release. :slight_smile: You can find it in the link below:

Can you give me more info about this? It should not have the “limit”. Do you mean bookmarks that appears in bookmark bar? Screenshot would be helpful. :slight_smile:

Thank you,
:slight_smile:


#3

OK, so now all the issues are back now except the LP icon does show up and the browser does open up fast. Seems like a random issue. I have no updates this time installed or downloaded this session.


#4

Seems a restart is necessary anytime these issues occur, restarting the browser won’t cut it.


#5

LP issues are back. Day 1, issue reported. day 2, it was OK and day 3, it was OK. Today, the symbol in the ID field shows but when I click it, and the ID that I want appears is clicked, nothing happens.The only way I can get rid of the box is to click the “X”.

Also, when at diynetwork.com, initially, I saw the login button at the top right corner where it always is but didn’t log in and tried to fill out a form which took me to page 2 of the form. When submitting the 2nd part, nothing happens when I click send. I went back to try to log in and the log in link was nowhere to be found. I reloaded the page and restarted the browser multiple times and nothing, it’s gone.

Pretty insane how one day, things are great and the next, it’s bad. I love the potential of the browser and the movement behind it but at this point, it seems Brave isn’t ready at least for me, as a primary browser. I have used Brave for four days now and have reported a new issue 3/4, possibly 4/4 days so far. I hope the dev team and support continue to improve the product and work out the bugs soon as these are pretty basic browsing functions that need to be addressed before more advanced features are considered.

I’m not sure how long Brave has been out for so this may be out of line, but I’m not trying to bash Brave, rather trying to be helpful to point out major bugs (that come and go) that make basic tasks irritating. I won’t install Chrome again but prehaps IE for now. Thank you for your time.


#6

Will also ccing @LaurenWags for additional answer.


#7

Hi @DUTCH81

Could you please open a new tab and go to about:preferences and open Extensions. What version of LastPass is on this page?

Thanks,
Lauren

cc: @kamil and @sriram


#8

4.1.45.87 is the version.


#9

This topic was automatically closed 60 days after the last reply. New replies are no longer allowed.