Issues with Flags on Brave

Ever since I changed one of the flags on Brave the prompt to relaunch brave on settings is permanently stuck there. I tried changing back the flags to default but that didn’t work either.

Issue: Prompt to relaunch Brave won’t go away

Producing the error: Change a flag and then reset them to default, the prompt to relaunch Brave should be there even after it’s relaunched multiple times.


Brave Version: 0.70.122

Did you return them to default by using the button at the top of the page, or did you simply switch the flag you changed back to its original setting?

Also, can you share a screenshot of the issue as it appears on your end?



If I recall correctly I switched them back to default by using the button @Mattches

Hmmm interesting. Is the button responsive? That is, if you click Relaunch now, does it relaunch? Also, does the banner appear on websites as well, or just on internal pages like Settings?


No, it only appears on the settings pages.
Thanks for the support so far! @Mattches

Now that’s real weird. Have you rebooted your PC since this started? I know that seems like a very trivial fix but it’s worth trying, if you don’t mind. In the interim, I’m going to try and reproduce the error on my side.

Yes I have.

Thanks! @Mattches

So I can’t seem to reproduce the error. Using the Reset all to default button worked and I only saw the Relaunch option once. Do you know what flags you changed by chance?

Also, do you have any extensions installed?

Only the “force dark mode” one.

Not currently.

Sorry for the late reply – checking in to see if you’re still encountering this issue? This is a fairly bizarre one that I can’t seem to reproduce nor do I see any other reports of.

Yep, I am still encountering the issue. @Mattches

If you create a new browser profile (Menu --> Create new profile) and go to Settings using that profile, does the Relaunch banner appear here as well?

Nope, it doesn’t. Strange, right? @Mattches

Very much so!
Can you try disabling Hardware Acceleration in Settings and see if this has any effect? It will also require a browser relaunch so, at least the button is already there for you :wink:
Settings --> Additional --> System --> Hardware Acceleration

Hardware acceleration was already disabled but, I enabled it and disabled it again to try and the banner is still there @Mattches Didn’t work :frowning:

1 Like

:thinking: :thinking: :thinking:
Reaching out to some team members because I’m fresh out of ideas.
Have you tried hitting the Reset all to default button in brave://flags again?

Didn’t work @Mattches

Are you using Windows 10 OS?

To confirm, you only had the force-dark-mode flag enabled, which you then disabled by using the Reset all to defaults button at the top. The banner to relaunch the browser appeared and after you clicked it, the banner now remains on Brave’s Settings pages.

  • No extensions installed
  • No flags enabled anymore


  • Provoking the banner so that it would dismiss itself using Hardware Acceleration toggle didn’t work :x:
  • Rebooting the PC did not resolve it :x:
  • Banner does not appear in new browsing profile (:white_check_mark:??)

Have you tried clearing your Cache/Site data?

Sorry for the late reply! How do I clean my Cache/Site data?