Issues using keyboard shortcuts in latest Tumblr update

Hi everyone, I’ve noticed ever since Tumblr updated again (as of a few days ago for myself, others have been in beta for a couple months but I was not) some of the keyboard shortcuts for navigating don’t work as they usually do.

I’ve already reached out to Tumblr but they say they don’t support Brave as a browser but Chrome works fine and to my understanding they have the same structure…? (I am not a computer person.)

Even with shields down the issue persists and I’ve tried it in regular chrome and there is no issue.

I’m speaking of using the “j” key to navigate through posts to be precise.

Site functions as normal as far as I can tell except the dodgy “j” key navigation. Sometimes it will work, sometimes no.

I have Brave version: [Version 1.5.115 Chromium: 80.0.3987.149 (Official Build) (64-bit)]
The latest according to my browser.

It’s obviously not a major issue it’s just inconvenient and I don’t understand why!

1 Like

Hi @ronanporter, welcome to Community!

Can you give me some more information as to the issue you’re experiencing with the J key navigation. I’ve tried it myself and J seems to be working fine.

Also, do you have any extensions enabled?

Hi @Aa-ron, thanks for replying!

I disabled the one extension that should do anything on Tumblr (XKit) since it doesn’t work since the new update anyway. I disabled all the others to test it out and I’m still having the same issue.

Basically I can still sometimes skip using J but it’ll only skip through a post or two (sometimes three) before not working. Then I have to scroll using the arrow keys or my touchpad past the top of the post and then I can hit J and it’ll skip. So I can’t continuously use J I have to stop and scroll a bit every few posts. Does that make sense?
It works fine on Chrome!

I have the same issue. I use chrome and have always used the shortcuts; J to down-scroll, K to up-scroll, and used it to queue and repost. I noticed the J only works sometimes too since the new update

1 Like

@ronanporter @beanz,
Can you both try creating a new profile and trying the J navigation in tumblr again.

It works!!! What’s the difference??

Well, that means there’s something in your main profile that is messing with the site’s navigation.

If you go to brave://extensions/shortcuts in your original profile, are there any shortcuts that involve J?

Can you also try going to brave://settings/content/siteDetails?site=https%3A%2F%2Fwww.tumblr.com and clearing data and reseting site permissions.

Alright I tried both your suggestions. There are no shortcuts involving J. I cleared data and reset site permissions and the problem is the same. I even went to the new profile and tried to match the permissions with it but it still doesn’t work.

The J navigation also works on Community. Can you try it here (using your main profile) and seeing if you experience any issues with it?

Here is a link to another topic in Community. Ignore the content, I’ve only chosen this topic because it has a lot of replies making it good for testing navigation.

Also try your new profile? Does that work fine as well?

The J navigation does work for me here on Community, it seems to be just Tumblr where it doesn’t. I tried it on the new profile and it also works in Community.

I had the same problem and I switched to 100% (Standard) zoom on my browser and it fixed it. Seems like they haven’t done the code for using the hotkeys when you’re zoomed in/out.

1 Like

Only just seen this, you’re exactly right, just tested it. What a dumb problem!!!

Thanks so much :slight_smile:

Obviously need to invest in a bigger screen next time I upgrade so I don’t need to keep zooming out…

1 Like

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.