Issue with HTTPS Everywhere and localhost

https

#1

I want to use HTTPS Everywhere, but I want to prevent it on a few certain domains… specifically domains setup in my hosts file for the loopback ip.

I can get “127.0.0.1” and “localhost” on HTTP just fine, but when I use a domain for example “myproject.dev” which has a listing in my hosts file as “127.0.0.1 myproject.dev” I am sent to HTTPS and I can’t seem to find a way to fix it.

Currently, I am sent to HTTPS even when it is completely turned off… BUT I can access 127.0.0.1 over HTTP without any issue.


#2

Hi @p_s,

.dev is a gTLD owned by Google. And these domains are preloaded with an HSTS header AFAIK. I think the result is same with other browsers. Maybe you can use something like .testing or .localhost instead.

Best,
:slight_smile:


#3

This topic was automatically closed 60 days after the last reply. New replies are no longer allowed.