ISSUE: Very Slow Launch When Brave is NOT Running

ISSUE: Very Slow Launch When Brave is NOT Running

I am experiencing the same exact issue as reported here:

Description of the issue:
Every time I start up Brave when there are not instances of Brave active it takes about ~25 seconds to launch. When there is already an instance running Brave is running smoothly (new tabs etc.), it only happens on startup.

Differences with my setup

  1. I’m running the latest version of Brave:
    Brave Browser 78.1.0.1 (100.1)
  2. I’m running macOS 10.14.6 (Mojave)
  3. It takes ~20 seconds before Brave is fully loaded.
  4. ALL extensions are disabled.

This is totally unacceptable

  1. This issue has been reported for months
  2. It does NOT occur with Google Chrome, Vlvaldi, or any other Chromuin-based browser
  3. It makes Brave Browser unusable

So, until it is fixed, I am switching to Vivaldi, and maybe I’ll find I even like it better.

Thanks for your prompt attention to this issue.

2 Likes

@JMichaelTX,
Can you/have you tried clearing your browsing history/cache?

Yes, it did NOT help, just as it did NOT in all of the other cases.

This is NOT an issue with me or my Mac. It is an issue with Brave Browser. Please investigate.

I’m having the same problem. When the scanner is turned on, it slows down as if loading something. I think Brave sync or Brave adblock is causing it.

1 Like

I would be happy to turn OFF both of these, but can NOT find a way to do so.

Anyone know how to turn OFF Sync and Adblock?

@JMichaelTX,
If your device is part of a Sync chain, go to Menu --> Sync --> Leave Sync chain. If not, try launching the browser from the macOS Terminal with the --disable-brave-sync flag. The full command would be (in terminal window):
open -a Brave-Browser.app --disable-brave-sync

@Mattches, thanks for the suggestions. Unfortunately, none of them worked.

The “Leave Sync chain” option was NOT shown.

That failed with this response:

$ open -a Brave-Browser.app --disable-brave-sync
open: unrecognized option `–disable-brave-sync’
Usage: open [-e] [-t] [-f] [-W] [-R] [-n] [-g] [-h] [-s ][-b ] [-a ] [filenames] [–args arguments]
Help: Open opens files from a shell.
By default, opens each file using the default application for that file.
If the file is in the form of a URL, the file will be opened as a URL.

I haven’t experienced this

@JMichaelTX,
You don’t see this option at the bottom of the page?

Also sorry about the Terminal command, it should actually be:
/Applications/Brave\ Browser.app/Contents/MacOS/Brave\ Browser --disable-brave-sync