Issue in specific site, does not work only in Brave

Description of the issue:
It eternally keeps loading, important point, this issue only appears in Brave browser, the site works perfectly in other browsers as Chrome, Firefox etc.

Steps to Reproduce (add as many as necessary): 1. 2. 3.
It affects randomly some users, disabling shields may help sometimes but the steps to reproduce is just going to the site https://app.aave.com - and for example selecting the option browser wallet (using brave wallet) or continue without wallet, does not matter specifically the option.

Actual Result (gifs and screenshots are welcome!):

Expected result:
Or it works, or it keeps eternally loading, affects randomly some users others not, works in other browsers perfectly.

Reproduces how often:
Quite randomly, some users may never experience the issue, some others always experience it, so I would say from 20-50% range.

Operating System and Brave Version(See the About Brave page in the main menu):
Multiple versions tested, always recommend to update to the latest available but it keeps failing.
Both Chrome and Mac, versions from 1.8 and above, currently failed in 1.8.90

Additional Information:
This error only happens in Brave browser, so its related with the browser itself we would like the site to work for Brave users as unfortunately right now the only option is telling the users to use another browser.

Error in the console appearing:
“Unchecked runtime.lastError: Could not establish connection. Receiving end does not exist.”

This might help a lot debugging.

If there is another way to report a bug on Brave please let me know, I would personally love to recommend Brave but literally I need to tell any visitor to use other browser because of this error, it only appears in Brave browser.