Is there a way to turn off the brave VPN?

My school has set up a VPN detector which turns off your wifi if you’re using a VPN. I noticed that while using brave at my school my wifi stops working until I shut down brave in which case it turns back on. I have to assume that it’s something to do with Braves VPN triggering this school system. So I was wondering if there is a way to turn off any feature which may be causing this issue or if there is any other work around. Thanks for any help.

@BaconWrapple

Brave Support will need:

  • your Brave Browser version numbers
  • type of computing device and its OS version numbers
  • VPN product description/name that you are using

Are you the owner of the computing device in question?

Does the school have some policy control ABOARD your computing device? (Could be an extension or add-on installed.)

UPDATE

An example of using something that had to be downloaded and installed on your computing device, in order to establish a Wi-Fi connection - Eduroam Configuration Assistant:

Possibly your school is using a Radius server and certificates for its Wi-Fi users. And, in order to connect, you are required to Sign In to the school Wi-Fi by using an Internet browser window?

You might need to know the following; could be useful info (as a way to get around using an Internet browser window to connect with the school Wi-Fi) . . .

During the 802.1X negotiation, the RADIUS server presents its certificate to the device supplicant automatically. The RADIUS server certificate must be trusted by the supplicant by either anchoring trust to a particular certificate or to a list of expected hostnames matching the certificate’s host. Even when a certificate is issued by a known CA and listed in the trusted root store on the device, it must also be trusted for a particular purpose. In this case the server’s certificate must be trusted for the RADIUS service. This is done either manually, when joining an enterprise network as the user is prompted to trust the certificate for the connected Wi-Fi network, or in a configuration profile.

Ref.:

Sounds like the school Wi-Fi support, is able to Deny access for your computing device’s assigned IP address.

Not so much a ‘VPN detector’ - instead, the school Wi-Fi service is not satisfied - when the service tries to mine information from your device and browser - and is frustrated by some of the protection methods baked in to Brave Browser.

Hi, I’m using a free version of the browser (1.39.111). I’m on a Macbook Air M1 version 12.4 (21F79. I am the owner of this device and there is no abroad policy control on the computer. I am not using any VPNs that I know of but since my internet shuts off when I use Brave I’m assuming that this is something to do with a baked in VPN in Brave. I was wondering if there is some sort of setting which may be triggering this school’s security system. Just to make it clear I have no use for a VPN I simply want to be able to use brave with internet as it’s my main browser.

@BaconWrapple

I updated my earlier reply. Brave Browser does not yet have a ‘baked in’ working VPN feature for desktop computing device users, but Brave developers are working toward that.

Sure but then what might be causing my school to block my wifi whilst brave is open?

@BaconWrapple

Without revealing any username -and- password combination, exactly how, step - by - step, is your MacBook Air M1 computer connected to the school Wi-Fi?

Do you have your Wi-Fi connection established by adjustments to System Preferences > Network settings?

Do you have your Wi-Fi connection estblished by using an Internet browser to reach a school website, where you Sign In?

Do you have your Wi-Fi connection established, by having previously downloaded a [Wi-Fi] configuration assistant, something like the Eduroam Configuration Assistant mentioned above?

Is your school using a Radius Server?

Unsure of what a Radius Server is exactly. But my wifi is established by going into system preferences > network settings if thats what you need.

@BaconWrapple

The fact that you use the System Preferences > Network settings in order to establish your Wi-Fi connection to the school, does help, here.

If you would go to those Network settings and select the ‘Advanced …’ button.

Questions:

  • For the ‘DNS’ tab, are there DNS numbers, listed?

  • For the ‘802.1x’ tab, are you using a Profile?

  • For the ‘Proxies’ tab, have you selected a Protocol to configure?

When you use Brave Browser at school, do you have a Window or Tab open to a school web page of any kind?

Have you tried using Brave Browser > New Private Window with Tor?

@BaconWrapple

Might not be a coincidence:

Go to System Preferences > Network > Location - Wi-Fi setup for your school Wi-Fi setup, and write down every detail of that setup.

When not at the school, you might completely disable and delete/remove your existing System Preferences > Network > Location - Wi-Fi setup . . . then Quit everything and Restart your Mac.

Next, when you return to the school, set up a new Wi-Fi connection.

Alternative: Set up a new Wi-Fi connection - as much as you can - BEFORE returning to the school . . . and then complete the setup and connection, when you return to the school.

Yeah although Brave works perfectly fine at home. Also here is the information you asked for a couple days ago (I haven’t been at school)

DNS Servers 10.2.208.21 & 10.2.208.22
No profile in 802.1x tab
No protocol to configure
I do not have a window or tab open to any sort of school website or interface
I cannot use the new incognito browser as I first have to open Brave which shuts my wifi down. It doesn’t seem to turn back on until I close Brave

Thanks for the help so far. Let me know if I didn’t quite answer your questions or if you have follow ups.