Is there a way to disable the update popup window?

One of my computers is relatively slow, sometimes causing the system to lag or freeze for several seconds when Brave’s update prompt decides to manifest itself. More than once, this has disrupted time sensitive activities or caused me to lose progress. An option to turn off the window would be appreciated - assuming that it doesn’t already exist and I’m too much of a dunce to find it.

Can you share a screenshot of the message? Additionally, what’s your Brave version? And OS?

You should always specify the environment you’re running on.

I can’t demonstrate on my openSuse Tumbleweed environment, or Android device, so produced the screenshot using a Windows 10 VM on openSuse - refer to the screenshot that follows.

First off, disable the update Services, so you

  1. Launch Services, navigate to the two Brave Services.
  2. Right-click (on each, in turn) and select Properties
  3. Select Stop for any that are running.
  4. For Startup Type, set to Disabled (or Manual), Apply, Ok.

You must also disable the associated Tasks - see the second screenshot

So now, auto-update won’t interrupt your work.

If you need to check for a Brave update, select its three-dash menu and select About Brave - you will see it check for a newer version, and if true, you can update there.

Disable these Tasks.
.
brave-tasks

1 Like