iPad multitasking (split view) opens links in Safari

Troubleshooting technical issues is much easier when both the user and support agent practice clear communication. For this reason, we have provided the template below for you to fill out with information about your issue. Please provide as much detail as possible so we can most efficiently resolve your problem.


Description of the issue:
Certain versions of iPad and iOS have multitasking capabilities with split screen, with which you can have multiple apps open side-by-side. See https://support.apple.com/en-us/HT207582. This feature can be turned off in iOS settings. However, Safari has special split screen functionality that enables two browser windows to be open at the same time. See https://support.apple.com/en-us/HT207522. Even when the multitasking feature is turned off, this special Safari split screen feature remains on (i.e., cannot be turned off). As a result, when using Brave, you can inadvertently open a link in Safari through split screen.

How can this issue be reproduced?

  1. On a split-screen compatible iPad device, go to Settings > Home Screen & Dock > Multitasking and toggle off Allow Multiple Apps.
  2. In landscape orientation, open Brave and navigate to https://www.wikipedia.org
  3. Press and hold the link for “English” for several seconds until the selected area pops out.
  4. While continuing to hold the link, drag the link to the left-hand side of the screen until you see the Safari icon appear.
  5. When you lift up your finger, the link open in Safari.

Expected result:
Either (1) the split-screen functionality is disabled in Brave or (2) the link opens in split screen in another Brave window (rather than a Safari window).

Brave Version( check About Brave): 1.19 (20.07.21.09)

Mobile Device details: iPad mini (5th generation) Model MUQW2LL/A

Additional Information: I realize that I could just avoid activating split screen by not dragging links to the side as described above. However, I’ve found that it is fairly easy to do it by mistake when scrolling through pages quickly and click links. Therefore, I’m not sure that this is technically a bug, but it would be nice if there were a way to disable this so as to minimize the risk of breaking the privacy chain.

I personally hate split screen because it is so easy to activate it by mistake. Really annoying.

The answer to your question has three letters: iOS. Safari is the default browser on iOS. This cannot be changed. Even Brave ist only another GUI on top of Safari. And this, I assume, is the reason why split screens in Brave will always open Safari instead of Brave.

There are several more limitations and odd behaviors all caused by iOS. Sure, Brave on iOS ist still beta and has a lot of its won bugs. But many things are simply caused by iOS.

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.