Intrusive calls to /feed and /comments/feed without request on website from Brave

Description of the issue:
Every time I call a page on my Wordpress website Brave adds 2 additional and intrusive calls under the hood to https://domain.com/feed and https://domain.com/comments/feed. This happens for every page as said, is reproducible with every single call. Not only does this spam my server logs, but also messes up my analytics logs completely. These calls happen completely under the hood and cannot even be seen by developer tools/network recording. You can only see it in the server and analytics logs. It is cross-tested with several other browsers where this clearly does not happen (Chrome, 2 different Chromium versions and builds, and Firefox). This is highly intrusive in my eyes and has to be fixed. Or, if you know from which setting this comes from, tell me how to turn it off please. I do not want to go the lengths now and record this in Wireshark as it can be clearly seen in the server logs that this is client-triggered, where it does not happen in any other browser. My logfiles are completely cluttered.

Please reply, many thanks.

How can this issue be reproduced?

  1. Call any page from my Wordpress website (in development, though not publicly here)

Expected result:
A single call to the page requested, and not 2 additional calls to /feed and /comments/feed

Brave Version( check About Brave):
v1.57.62

Additional Information:

1 Like

Can you please respond to this?!

I tested this further. It does not happen in Incognito mode. So in incognito it works as supposed to, like from any other browser.
The indication that these are in fact under-the-hood calls is even more clear because both of these calls always receive a 401 (the site is under basic_auth currently). So they are not seen from developer tools (ofc, they are not user triggered and are nowhere in any of the website code) and they receive a 401 although basic_auth is done in the browser window itself. Meaning if you directly call them from the address line they are returned with a 200, as supposed to.

I suppose that this might be some rogue code from your (Speed)reader functionality, which is turned off in fact in the settings.
This is not ok.

Please get back to me/us on that matter.

Thanks;

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.