Intermittent hang-up loading PostFinance eFinance pages

Running Brave Version 0.70.121 Chromium: 78.0.3904.70 (Official Build) (64-bit) under Win 10 vsn 1903
I’ve only been using Brave, basic default functionality, for about two months (generally v. impressed), so I’m not familiar with all options - sorry.

Logging on to e-finance of the Swiss “Post Office” banking system PostFinance is successful, but loading of home page stays at “is being loaded” for several minutes and then nothing. Only the logout function works! The problem is intermittent (5h1t), failing 9 out of 10 times.

The problem started about two weeks ago. I can’t recollect it being at the same time as any update - but my memory is very fallible.

MS Edge, Firefox and Chrome work fine.
Brave with the “shields down” for this site doesn’t fix it.

Any suggestions what else I might try? any further diagnostics?

TIA - DaPi

1 Like

if you disable sheilds does that make any difference @DaPi ?

As I said above shields down for this site changes nothing. Following fanboynz remark, I changed the shields options generally to be down, restarted Brave, and that didn’t change anything.

We now seem to be at version: Version 0.70.122 Chromium: 78.0.3904.87 (Official Build) (64-bit). The update happened “stealthily” so I’m not sure exactly when I got it.

My problem seems to have gone away. Correctly functioning on four tries so far, one with all shields up.
I hope it stays that way. DaPi

Perhaps I spoke too soon. The fault is less frequent - 50% of logins? When it happens, selecting another page (after the time-out), then selecting the Home page works!

Don’t you hate it when this kind of thing happens. (I’ve a similar problem with my car: only gives trouble when it’s cold and wet).

Any ideas? (Not about the car). DaPi

We now seem to be at Version 1.0.0 Chromium: 78.0.3904.97 (Official Build) (64-bit) - odd I never saw any fireworks to celebrate going to version 1. :slight_smile:

The only additional info I can add is that reducing the number of “tiles” (menu options) on the home page (which is customisable) increases the chance of the start-up working first time. Does this indicate it’s a time-out problem somewhere?

BTW I use this 4-6 times a day, so it can be a significant problem for me.

TIA - DaPi


I have the same problem except it won’t load at all on my side.

To access my postfinance account, I have to use another browser.

I have disabled the shield but nothing changed

The developer console is showing the following errors (Only on Brave browser) :

all.lib.min.js:10 Uncaught TypeError: Cannot read property 'value' of undefined
    at et (all.lib.min.js:10)
    at Object.<anonymous> (all.lib.min.js:10)
    at ar.extend.create.create (all.lib.min.js:6)
    at Function.d2 [as module] (all.lib.min.js:6)
    at new window.bp (all.lib.min.js:10)
    at all.lib.min.js:5
home:173 Uncaught TypeError: Cannot read property 'config' of undefined
    at home:173
all.launchpad.min.js:6 Uncaught TypeError: Cannot read property 'config' of undefined
    at all.launchpad.min.js:6 Uncaught TypeError: Cannot read property 'classes' of undefined
home:5363 Uncaught ReferenceError: gadgets is not defined
    at home:5363
home:6097 Uncaught TypeError: Cannot read property 'ef001' of undefined
    at home:6097
15Refused to execute script from '<URL>' because its MIME type ('text/html') is not executable, and strict MIME type checking is enabled.
all.launchpad.min.js:6 Uncaught Error: Load failed: lodash:
    at HTMLScriptElement.<anonymous> (all.launchpad.min.js:6)
all.launchpad.min.js:6 Uncaught Error: Load failed: jquery:
    at HTMLScriptElement.<anonymous> (all.launchpad.min.js:6)
all.launchpad.min.js:6 Uncaught Error: Load failed: angular:
    at HTMLScriptElement.<anonymous> (all.launchpad.min.js:6)

Hi Alexandre, Sorry to hear you’re having trouble too. But I’m a bit relieved that I’m not an aberration!

Now at Version 1.0.1 Chromium: 78.0.3904.108 (Official Build) (64-bit)
As of about 3 days ago things got significantly worse, failing almost consistently, back to the same level of success as when I started this thread.

How do I look at the developer console to diagnose this? OK, found it.

Thanks - DaPi

Hi DaPi,

Are you getting the same error message as me ?



Yes, the diagnostics in the dev console look identical.

We still seem to be at version 1.0.1. Today (10 dec 2019) new behaviour has developed - consistently over four logons:

  • initial load of Home page “times out” - errors as above
  • clicking on "Offers"works - nothing in Dev Console
  • clicking on “Home” works - nothing in Dev Console

Curiouser and curiouser

Now at 1.1.23 - behaviour remains as on 10 Dec 2019

Hi DaPi,
It works now since last update :slight_smile:
Have a nice day

Hi Alex,

Glad it works for you.

I’m at version 1.1.23 and still the situation as 10 Dec:

  • initial load of Home page “times out”
  • clicking on "Offers"works
  • clicking on “Home” works

I can live with that but it’s annoying - DaPi


You’re right, today it is not working anymore.

I guess new years eve recuperation gave me hallucination…

Hope it will be fixed soon so we don’t have to keep another browser for e-finance only.

Well now at Version 1.3.115
The problem persists but now:

  • initial load of Home page “times out”
  • clicking on “Home” works

About one time in 25(?) the initial load works OK too.
Annoying but not so bad to make me change browsers - DaPi

Hi DaPi,

Found out that the extension Wappalyzer was causing the issue on my side. Could you please check if you have an extension making Postfinance not working ?

Hi Alex,
Thanks for this lead. The only extension I have is LastPass. Removing that for a test will take a moment - I’ll let you know when I have time.
Thanks again - DaPi

Hi fanboynz

Purely by luck I can add some info here:

  • if I login to PostFinance with or without the shields up, there is this long (one minute?) delay and then the process times out (and I can now - vsn [1.4.96] - successfully load the Home page by clicking on “Home”).
  • if during this delay I click on the “Lion” icon, next to the URL bar, and make ANY change to the shield parameters (up/down, cross-site trackers . . . ) the page loads immediately!

Does that help? - DaPi

Maybe try a new profile, or test in Brave Nightly Release? Hard to say tbo.