Installing on Android TVs

Has anybody managed to install Brave on an Android TV (not a TV box), perhaps specifically a Philips TV?

It doesn’t show up in the sandboxed version of the Google Play app and I have tried sideloading using various file explorers which has worked with other apps. I have also tried using a few APK repositories like APKpure and Aptoide but whilst they appeared to have installed Brave, nothing appeared in the app list.

I thought about trying to install another browser and use that to circumvent the excuse of a version of the Google Play store but could not find any other browser apart from one I had never heard of but was even worse than the pre-installed browser.

It almost seems like no other browsers can be used or even installed. The television is well outside its warranty so any argument that Philips were to make that it was about protecting my safety or whatever would be past its sell by date.

I’d be interested in any comments - even a definitive ‘can’t be done’ if it saves me the grief of continued pointless effort.

Hello @okulo

most probably your android version is old as the min required version is 7 right now

download the apk from apkpure or any ther resource would not help as it still need android version 7 or more

so what you can do

  1. try to find the android version that your tv has if it less than 7 then you know the cause of the issue now

  2. check if there some where on the tv that allow you to update it (in officially way not using custom rom)

  3. if you have no way to upgrade to version 7 then you can go to the which has apk file for android for all version they release which will require some searching also to use the right apk for your arch for example this latest version
    has many apk arch

Pick the APK suitable for your device's architecture.

hope that help and have a nice day :slight_smile:

Actually, the Philips TV is running Android 8.0.0. I already tried installing the version of the apk you linked to. After supposedly installing it (I got the installation screen and the progress bar completed and I got a success message), Brave appeared to have been installed as the installer gave the option to open the app but it did not open. Brave does not appear amongst the installed apps BUT if I look at app permissions, specifically which apps can install apps, Brave is there and enabled.

I have tried most of the browsers on my Android TV, at this moment Brave is the one that works best with small memory and small storage space (1.6GB free left of my TV set).
I use to download the apk from
An annoyance I just found
There are cookies that I cannot delete
My wish list
Add support for EME
Videos that needs this feature I use to watch using KIWI browser + extensions

Written and sent from Brave browser on Android TV

What brand of television is it, if you don’t mind me asking?

now the android version is not the issue

if you have any other browser on your tv could you go to hope it give you notice that you can open it using the playstore and once it opened it will report if there issue for why it not appear on your play store

another thing did you choose the right arch for the apk as there many apk from the link i mentioned

hope that help and have a nice day :slight_smile:

As already pointed out, the built in browser and the only other browser I can install via the version of the Google Play app installed on the television are garbage - they make the AOL browser look good and hang when challenged by anything remotely out of their comfort zone.

I can install to my devices from any other device via the Google Play Store site, though, but this is what I see (screenshot from Brave/iPad). I have Brave already installed on my A95X Max but apparently, it is incompatible with the Philips TV. By the way, this is where I began a week or so ago but having had success installing other apps not on Philips’ white list, many of which I downloaded and installed from GitHub or other apk repository, I was determined to find another way.

By the way, that (TPM171E0) is not the Philips TV model number (it is actually 49PUS8503), that must be some part of the architecture.

not sure if that would make difference

based on that and your tv is using arm 64

so i would try those apk Bravearm64Universal.apk BraveMonoarm64.apk

so install one and see if it work and if not remove it and install the other

another thing is to try to use older version of brave and see if it work or use the beta or night version

It is a TCL who owns the brand

Información del producto V8-R41KT01-LF1V325.008616

Nivel del parche de seguridad de Android
5 de septiembre de 2020

Versión del kemel
#58 Fri Nov 20 00:57:48 CST 2020

PPR2.180905.006.A1 release-keys

Información de Brave

Versión de la aplicación

Brave 1.56.20, Chromium 115.0.5790.171

Sistema operativo
Android 9; Build/PPR2.180905.006.A1

Información legal
Copyright 2023 Brave LLC. Todos los derechos reservados.

Información de Kiwi Browser

Versión de la aplicación Kiwi Browser 116.0.5845.61

Sistema operativo
Android 9; Union TV Build/PPR2.180905.006.A1

Información legal
Copyright 2023 Geometry OU. Todos los derechos reservados.

I forgot to comment that I use it as a desktop PC, with wired keyboard and mouse connected to the only USB port of the TV through a USB hub.

I also tried Firefox but it doesn’t work well, seems it needs more system resources,

I also installed Brave in a no-brand TV Box and found it works without problems. Here I use the remote control pointer to navigate.


Nivel de parche de seguridad de Android
1 de diciembre de 2017

Versión del kernel
wyj@ubuntu #63
Wed May 29 10:27:44 CST 2019

p281-userdebug 7.1.2 NHG47L 20190529 test-keys

Información de Brave

Versión de la aplicación
Brave 1.56.20, Chromium 115.0.5790.171

Sistema operativo Android 7.1.2: Build/NHG47L

Información legal
Copyright © 2023 Brave LLC. Todos los derechos reservados.

Yes, so have I (see post with screenshot), that’s why I specified TV not TV box in my original post. I am pretty convinced that the problem installing Brave on Philips TVs is down to Philips blocking anything that they do not approve of and not a limitation of the television’s specifications. But it seems that they are particularly targeting browsers as you cannot even install ‘old school’ browsers like Firefox or Opera.

it could be sorry i do not have philips tv to test it

You should contact Philips customer support

They are deliberately trying to prevent the installation of apps they disapprove of do I doubt they will want to help.

Philips TV comes with Android Operating System, Roku TV OS, Saphi OS.
If your TV has Android OS there must be a way to install any Android app.

There ought to be a way but Philips made it as difficult as they could.

The pre-installed supposed Google Play app only has a very limited selection of apps and as I have said, I have installed quite a few apps via downloaded apk files which I copied to USB from my Mac. I can’t get at the television for a few days but on Wednesday or Thursday, I will be making a new assault on it. I’ve found some key combinations to possibly access a deeper level of preferences.

Well, this is how it went.

I had a brief window to play with the television. I don’t know if this helped in any way whatsoever but I enabled developer options by clicking the build number in Android settings five times (maybe more but the interface shows a countdown so you know). However, I’m 99.99% convinced that this did not make any difference to the eventual outcome.

The Philips TV Home Screen/launcher is an ad-fest full of garbage that does not interest me and there is a row of apps along the middle which you can add to but when you try to add apps, you can only see apps which the TV shows in its curated installed app list - so if it isn’t listed, you can’t add it to the launcher, neither can you change the launcher (I have an Android TV box so I can see how the settings usually are). However, you can install a launcher, which I did, and when the launcher is opened, all the apps which seemed to disappear after being installed are listed, including Brave and Opera.

Unfortunately, when Brave was opened, the screen went white, then rotated 90°, went black then quit. Opera would work so using that, I found and installed the Bravearm64Universal.apk mentioned earlier. When I launched that version, I got the rotating white screen again, then black then a Brave splash screen at 90° but then it quit - but some kind of progress.

I then tried installing BraveMonoarm64.apk. That also did the rotating white screen, black screen, 90° Brave splash screen but went to a 90° welcome screen with options which were almost impossible to navigate at 90° with an air mouse but I managed and thankfully, the screen rotated 90° back and seems to be working.

I don’t use the television for watching anything other than SmartTube, Rumble and Kodi, so all the stuff that it tries to ram down my throat is wasted and it is a pain having to find stuff it hides from me. I’d be happy with a Home Screen with nothing but a few buttons to the apps I use- but it has a great picture and it was at a fantastic discount about three years ago (though I bought it new it was a two year old model).

Anyway, all seems to be good(ish) now. Thanks for the contributions.

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.