Installing Carthage for Xcode 8.3.3


#1

Hi,

I am trying to setup environment for iOS browser(older version), for that it needs Xcode 8.3.3, and * Swift 3.0. I have downloaded, Xcode 8.3.3 and I followed the instruction which was mentioned in the github.com/brave/browser-ios.

When I ran a command for to install Carthage: brew install carthage

I got this error, Error: Your Xcode (8.3.3) is too outdated.
Please update to Xcode 9.2 (or delete it).
Xcode can be updated from the App Store.

Can any one help me for to install Carthage for the Xcode 8.3.3.

Looking forward for your kind help.

Thanks in advance.


#2

Hi @shiladkumar.d. Any reason why you are trying to set up the older version?


#3

You need to download an earlier version of the app. I think we switched to Xcode 9 on 1.5, so https://github.com/brave/browser-ios/releases/tag/brave1.4.2 should be compatible with Xcode 8.

There’s commit that bumped Xcode version https://github.com/brave/browser-ios/commit/feef38eac5535f8ff3930abac8f2ac5b1a9e8b5c. You can just fetch version before this commit and it should run just fine.


#4

Hi @sriram.

Thanks for your mail. Yeah, I have few dependencies, got few features developed using older version of swift, and unable to convert completely that into the newer version(getting errors), so would like to use the older version.

Thanks.


#5

Hi @michal,

Thanks for your reply.


#6

This topic was automatically closed 60 days after the last reply. New replies are no longer allowed.