Installed Brave Browser Apps do not open with latest release

Description of the issue:
I installed 3 brave browser apps weeks ago. Those apps are

They all worked perfectly up until this morning. As of the latest update when I click on those applications they flash on my Mac doc for a few seconds and then fail to open. I’ve tried reinstalling the apps from their respective websites and the behavior remains the same.

How can this issue be reproduced?

  1. On Mac 11.6.1 using Brave Version 1.35.104 Chromium: 98.0.4758.109 (Official Build) (x86_64)
    Goto, or and install their apps using brave
  2. Click on the app in the /Users/[username]/Applications/BraveBrowser Apps
  3. The app doesn’t open

Expected result:

The application opens in it’s own window. It had been working this way until I installed the latest version of Brave

Brave Version( check About Brave):

Version 1.35.104 Chromium: 98.0.4758.109 (Official Build) (x86_64)

Additional Information:

Hi and welcome to the community. This was an issue with version 1.35.104 release but appears to be resolved with the new release, version 1.36.109. If your Brave Version entry above is correct, you should install version 1.36.109 and see if that resolves the issue.

1 Like

@russelldad , @Chocoholic ,

To be clear, BEFORE installing all three app’s, you double-checked to be certain that each of them, is a Progressive Web Application (“PWA”)? (Re what @Chocoholic wrote about.)

To be clear, you [re]searched online the Internet, for info that would cover the possible conflict in application names being the same (in addition to purposes of said applications), that are,

A) the Apple native located on a Mac, here:



B) your Google installation:

~/Applications/BraveBrowser Apps/

When, as you wrote, “the app doesn’t open” . . . let us say, that was in regard to the Google “” that you installed as a PWA, did you then test the Apple native “” to see if it would start?

Have you, by chance, discovered conflicts between the two “” processes?

Have you been monitoring the Brave Browser > Task Manager for indications of the “” PWA process (and the other processes)?

@289wk oh dear, I just noticed he was on the older version of Brave where that issue and related app issues were happening. I just wanted to suggest that installing the newest version may resolve the issue. I have run across several community members who say the new release, version 1.36.109 solved their app opening issues on Mac OS.

If it doesn’t, I have no clue where to go from there! I have never used a Mac and know nothing about it! :laughing: The information you provided will probably be helpful if the problem persists after updating to the newest version. :smiley:

@Chocoholic ,

You did not do anything wrong. I messed up, by not properly addressing russelldad in my reply, above. (Fixed)

And you had the solution.

@Chocoholic Thanks so much for the quick reply. I thought I had upgraded to the latest version, but clearly that wasn’t the case. I just upgraded to Version 1.36.109 Chromium: 99.0.4844.51 (Official Build) (x86_64) and the apps are once again working.

Thanks again. I really appreciate it!


This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.