Install problems on Linux Mint 21.0

Description of the issue:
I cannot install Brave on linux mint 21 using the instructions at https://brave.com/linux/#linux
and I cannot access https://support.brave.com/ to find out why.

Steps to Reproduce (add as many as necessary): 1. 2. 3.

  1. open terminal with ctrl-Alt-t
  2. cut and paste sudo apt install apt-transport-https curl gnupg and enter password

Reading package lists… Done
Building dependency tree
Reading state information… Done
curl is already the newest version (7.68.0-1ubuntu2.4).
gnupg is already the newest version (2.2.19-3ubuntu2.1).
apt-transport-https is already the newest version (2.0.4).
0 upgraded, 0 newly installed, 0 to remove and 24 not upgraded.

  1. cut and paste curl -s https://brave-browser-apt-release.s3.brave.com/brave-core.asc | sudo apt-key --keyring /etc/apt/trusted.gpg.d/brave-browser-release.gpg add -

gpg: no valid OpenPGP data found.

  1. click on “help centre” link at the bottom of page https://brave.com/linux/#linux
  • using Google Chrome Version 88.0.4324.182 (Official Build) (64-bit)

Your connection is not private

Attackers might be trying to steal your information from support brave com (for example, passwords, messages or credit cards). Learn more

NET::ERR_CERT_AUTHORITY_INVALID

  • Using Waterfox Current 2020.10 (64-bit)

Did Not Connect: Potential Security Issue

Waterfox detected a potential security threat and did not continue to support brave com because this website requires a secure connection.

support brave com has a security policy called HTTP Strict Transport Security (HSTS), which means that Waterfox can only connect to it securely. You can’t add an exception to visit this site.

  • Using waterfox classic 2021.02 (64-bit)

Your connection is not secure

The owner of support brave com has configured their website improperly. To protect your information from being stolen, Waterfox has not connected to this website.

  • Using firefox 85.0.1 (64-bit)

Did Not Connect: Potential Security Issue

Firefox detected a potential security threat and did not continue to support brave com because this website requires a secure connection.

support brave com has a security policy called HTTP Strict Transport Security (HSTS), which means that Firefox can only connect to it securely. You can’t add an exception to visit this site.

Reproduces how often:
constantly 2020/02/20 and 2020/02/21

Operating System and Brave Version(See the About Brave page in the main menu):
Linux Mint 20.1 Cinnamon
Cinnamon version 4.8.6
Kernel 5.8.0-43-generic

Aditional information
I had to de-link the repeated references to support brave com in the error messages as they exceeded the number of links allowed for new users

1 Like