Instal issue with Mac OS Monterey

Dear community,

I downloaded Brave on my Mac OS Monterey (M1 2020) and the application does not want to launch when I open it.

The error message is: Brave browser quit unexpectedly (click on Restart to reopen the application…)

I took care to close all applications.

Thank you for your help and support on the subject

kind regards
Ben74 (France)

Try the pkg that Mattches suggests:

But use the following URL address for the latest release:

Dear @Zig-Zag and GitHub,

Thanks for your support.
Unfortunately, still not possible to open Brave. I tried for my Mac Os with Brave-Browser-arm64.pkg and Brave-Browser-arm64.dmg as well… but always the same error response…
Please find report attached if it can helps.

I you have any idea…
Thanks and regards

Hi @Ben74 ,

did you try this one already?

That helped me. After installing I had to delete this BraveSoftware folder which is a hidden Folder. In the marked Thread you can see how to make that folder visible for deleting.


Dear @ZiG-ZaG,

Wonderful, it works. I deleted the concerned file in the library and everything gets fine.
Thanks for your kind help and support.
Much appreciated.


You are welcome :+1: