Infinity load in random pages ( ⇦ Slow loading or No loading)

Same problem brave user from start and now this problem with no loading only few pages from whole internet loading for me.They need to act ASAP and fix this.

1 Like

Disabled extensions…no change
bit warden password manager
deepl translate
grammar & spell checker
web RTC network limiter
youtube to mp3 converter

Disabled/enbled hardware aceleration…No change
WIped brave…
sudo apt purge package/app name
sudo apt autoremove
Reinstalled …No Change…
Tried on a number of different sites…same result
Reset ‘settings’ to default…No change

Heartily sick and tired of this. it obviously is not OS specific.
It is BRAVE.

“” rebron added this to Untriaged Backlog in General 8 hours ago

Might I suggest that this becomes a PRIORITY fix ?
Your browser and its reputation are slowly but surely going down the gurgler

1 Like

At a quick glance, a fresh test profile appears to work normally with sites I’ve found to be slow-loading under this issue (e.g. and Reddit) , but I haven’t tried using it for an extended period of time. This seems to be similar to the experience I mentioned earlier with a secondary profile I also use (set up prior to this issue), although others report still experiencing the issue with their other profiles.

1 Like

This doesn’t seems to be a issue with profiles.
In clean install of the browser the issue still persist. In Github there are references to the De-AMP function, but still not confirmed…

And disable that function also doesn’t help.

1 Like

Posting to subscribe and report same on Macos with version 1.39.111.

1 Like

Don’t forget to keep track of the GitHub. They are actually working on triage now and asking people experiencing the issue to try a variety of things and provide feedback. For example:

The quote above is from


Latest Update, received this morning Sydney Australia time 7.15am
Version 1.39.120 Chromium: 102.0.5005.99 (Official Build) (64-bit)

Appears to have resolved this issue.

_I cleared cached images and history and cached files, cookies etc to give its best chance. _

I am now able to middle click many, many links (up to 20 clicked on in a matter of seconds) etc and they will all open as intended…No more failing to load.

Thank you Brave Support


It saddens me to report on this issue as well. Well, I just did a fresh install of windows. Before I did not have this issue.
Now Whenever I click a link inside brave or inside windows when brave is closed it would just show me a blank white page without anything loading. As soon as I refresh the page, it loads normally.
Same brave version everything. Only difference is fresh install of windows 11. It was the same windows 11 before.
Kinda annoying issue to have tbh.

I will try to do what condo above me mentioned. Even though I tried to avoid that. I even backed up and imported my brave user folder to not have to deal with addon settings etc to save time and pain.

Deleting cookies etc solved the problem for what it looks like so far for me aswell.

1 Like

I’m having the same problem. I thought only I had this due to some flags i changed… This problem started maybe 2 weeks ago.

You can fix this problem if you refresh page again

Version 1.39.120 Chromium: 102.0.5005.99 (Official Build) (64-bit)

Changed flags:


Just delete cookies, website data etc in brave. And 8t should be fixed. That did it for me

1 Like

I’ve installed Brave browser v1.40.57 (Pre-release), issue that about this topic seems to be improved.
I’ll use it for a while and see how it goes

the next update will fix this issue.

Updated to 1.39.120 on Macos. Still same problem.


I was suffering from extremely slow loading on the first time a website is acessed, since version 1.39.111. I’m using the flatpak Brave on Ubuntu linux (22.04).
But the upgrade to 1.39.120 resolved the issue.

1 Like

I don’t recommend using anything other than Brave regular.

2 years ago I used Brave Dev version and it broke so many things I had to go back to Brave regular version. It’s why I never go back to testing releases, I had to transfer all my extension databases, all extensions, all history, cookies, etc. to normal version of which many were not compatible backwards…

1 Like

problem continues, even after yesterdays update (1.39.120)

Topic at Github :



Response from ‘’ and a Cloudflare server. The following situation will delay, where I had not yet Allowed the website as a JavaScript source.

1 Like

Now, after maybe six hours doing OK, the problem is back!


@emerkkn , @Akihiro2526

I mostly run into the problem, when failing to do that (turning JavaScript ‘ON’ - ie Enabling JavaScript - for the specific website), or needing to Allow one or more sources for JavaScript(s).

Otherwise, either stop the load and then reload / refresh the page, or right-click on the link and select in the pop-up menu: [whatever is the] open in a new window [selection].

Making a more determined effort . . .

Given that you are attempting to visit a website:

There is usually an icon that is immediately to the left of the URL address field in a Brave Browser window.

IF you can right-click on that icon and get the pop-down menu, then Enable: JavaScript for the website.


IF you cannot right-click on that icon, then choose one of the following 2 actions:

(A): In a Brave Browser > New Window, go to:

  • brave://settings/content/siteDetails?

Scroll down and Enable: JavaScript

(B): In a Brave Browser > New Window, go to:

  • brave://settings/content/javascript

Scroll down that javascript settings page to Allowed to use javascript

Click the Add button

Enter [*.] as the site . . . but Do Not Enable

  • Current Private session only

Click the Add button

Try to visit the website again. Reload / refresh the web page, if at first you do not succeed.

1 Like

Chiming in to say I have this problem, too. Tried deleting cookies etc. Didn’t work.

Windows 11

1 Like

As stated before, delete cookies website data etc. This should fix the issue of websites not loading until you hit refresh page.
That’s what I did on win 11 and it fixed all issues relating to this problem.

Just delete that and it should be fixed.