Inertia scrolling suddenly stopped working

I use mac, and on the track pad I have Inertia scrolling enabled (when I scroll and let go of the track pad, the scroll will keep going for a bit.) In one specific website that I use several hours per day (tradingview.com) this scrolling suddenly stopped working, only in the Brave browser. I have contacted both Apple customer service and Tradingview customer service, but they said there must be a bug in my browser. My Brave Browser is up to date.

Any tips on how to make this work again? I tried to disable and enable Inertia scrolling on my mac, and it works fine everywhere expect on this website. It makes it pointless to scroll down my watchlist or anything else there, as it takes forever. Started to rather drag that thing on the right down as if it was 1999. Thank you!

@adrianwinther

I visited tradingview.com The Brave Browser site-specific Shields (Lion icon) panel reported 39 javascripts to Allow (I did Allow all the tradingview.com javascripts; 4 examples):

  • www.tradingview.com/static/localization/translations/en.995683e415a780ea.js
  • www.tradingview.com/static/bundles/runtime.bc84029f02324070d231.js
  • . . .
  • www.tradingview.com/static/bundles/47990.543909dd79292a26dc15.js
  • www.tradingview.com/static/bundles/main_page_promo.a06e6366268e16f1dfd3.js

Plus a source for javascripts:

  • www.tradingview.com

JavaScripts allowed, or not, the main tradingview.com webpage is lengthy and loaded with a lot of information - some, dynamic, that is being processed, though not visible when not yet scrolling.

My Mac’s cooling fans offering their perspective: a pronounced increase in speed, before any scrolling.

I monitored both the Brave Browser > Task Manager -and- the Mac’s Activity Monitor.app. CPU usage was anywhere between 10 - 25 percent (when adding up all the browser CPU usage).

I monitored the Brave Browser > Developer Tools > Network activity. There is a lot of interaction between website and browser, including pinging by the website (the pinging was blocked by some Brave Browser method).

I visited the website, using Firefox, and observed the same or similar reactions and response.

On your Mac, if Hardware Acceleration is Enabled, the OS may try to limit an approaching, higher state of CPU/GPU heat, by limiting Inertial Scrolling.

My Mac is not set to use Hardware Acceleration, and Inertial Scrolling was not interrupted.

Might also help:

Recommended in order to reduce influence by websites:

In a Brave Browser - New Window, go to: brave://settings/content

Scroll down to “Additional permissions” . . . and set:

  • Protocol handlers: Don't allow sites to handle protocols
  • File editing: Don't allow sites to edit files or folders on your device
  • Clipboard: Don't allow sites to see text or images on your clipboard
  • Window placement: Don't allow sites use info about your screens to open and place windows

Scroll down to “Content” . . . and set:

  • Pop-ups and redirects: Don't allow sites to send pop-ups or use redirects

Next, go to: brave://settings/cookies

  • Enable: Block third-party cookies
  • Disable: Clear cookies and site data when you close all windows