Imprivata Sign-In Does Not Work in Brave

Description of the issue:

Imprivata which is a 2-factor authentication service, does not work in Brave. The organization I work for uses Imprivata. It integrates with their Office 365 suite, which is where I’ve tested it.

I have confirmed that this issue is specific to Brave. I am able to login with Imprivata using Chome and Firefox.

As a part of my troubleshooting process, I’ve disabled the Brave shields on the login page. Additionally, I’ve changed the cookie settings to allow for all cookies. Neither of these remedies made any difference.

How can this issue be reproduced?

Unfortunately, you need to have access to an online application that utilizes Imprivata. So, there probably isn’t a great way to reproduce the problem. That said, I will describe my process in detail.

  1. Visit
  2. Login using my organization’s email address. This will redirect me to a separate login page, specific for my organization.
  3. Attempt to login with my organizations login credentials.
  4. When a login is attempted, I am prompted to confirm the attempt via Imprivata. Imprivata has a mobile application, which I have loaded on my mobile device. To confirm a login attempt, I open the app and click on the prompt to confirm the attempt.
  5. Once the attempt is confirmed, I should be successfully logged into Office 365. However, I’m unable to progress past this point. When I confirm the attempt on my phone, nothing happens. It’s as if the login page does not receive the confirmation.

Expected result: Noted above

Brave Version( check About Brave): V1.35.100

Additional Information:

Try it with shields off for the site. If it works this way then try turnining on shields for the site and futzing with individual setting for cookies, fingerprinting, etc. Lion head icon in address bar to get the shields config for the site. If it only works with shields completely off or not all, click the report broken site button.

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.