Importing settings with Default is not working

Description of the issue:
When trying to import settings by copy/pasting Default folder, Brave detects the new files as corrupted and resets all settings.

How can this issue be reproduced?
Does not work with every computer (but I have no idea why…)

  1. Copy a Default folder from another Brave config
  2. Paste the Default folder in ‘Users\UserName\AppData\Local\BraveSoftware\Brave-Browser\User Data’
  3. Open Brave settings and see if Brave shows a windows saying settings have been reset due to a program that would have corrupted settings.

Expected result:
The settings should have all been imported nicely, and the window about corrupted settings should be displayed.

Brave Version( check About Brave):
Version 1.24.86 Chromium: 90.0.4430.212 (64 bits)

Additional Information:
OS is Windows 10

Thank you for your help!

Hi @ManonT, Welcome to Community!
There will be some issues transferring data. Why are you coping over your Default folder?

Hi, thank you for your quick reply!

I am trying to copy this folder, because I want to be able to easily and automatically copy settings to computers I configure (like having Google as search engine or having a new tab page show the homepage). I saw here and there that copying the folder was the standard procedure to import settings and it seems I am not the only one having trouble with this functionality…
I had already tried to copy the entire User Data folder, and it did work on one computer, but not on others, so I tried to copy only the Default folder. And the same happened: it worked great on one computer but not on any other.
I tried copying the folder using Python (shutil.copytree) and by hand, but the outcome is the same, whether it worked or not.

Any help understanding what’s happening is very welcome, I am so lost ^^’

Unfortunately, there is not much we can do here. Sometimes there can be corruption issues.
A better way to copy settings and other stuff over the different installations of Brave is to use Brave Sync (found at brave://settings/braveSync)

Thank you for your response! I don’t think I can use Brave Sync, but I’ll do a bit more research to be sure :slight_smile:
I don’t really understand how corruption issues happen (because depending on the computer I might have one or not…) so if you have any leads to help me, I’m interested!

Just a bit of update here, I think I found a workaround the corruption issues: instead of copying the entire Default folder, I just copy 4 files which are Preferences, Secure Preferences, Bookmarks (copied in Default) and Local State (copied in User Data).
From what I understood, these 4 files contain (at least) most of the Brave config, and copying them did not gave me a corrupted files issue.

Hope this’ll help :slight_smile: