Immediate crash or opens to blank window on Catalina 10.15.7 (Patcher)

Have already seen Brave immediate crash on Catalina - #6 by rolya, which offers no solution, as well as any of the other topics related to crashing on Catalina.

Impossible to open or run, except from new install package using open /Applications/Brave\ Browser.app --args --no-sandbox from the command line.

*Note, even if I use the command line option to open, Brave crashes if used with the App and Software which does run in Ventura. Must use new install package, with everything from any prior installations deleted.

Have tried absolutely everything and this command line option is the only way I can get Brave to open on 10.15.7.

When opened as such, it is accompanied by warning “You are using an unsupported command-line flag: --no-sandbox. Stability and security will suffer.”

Questions:

-What might I be missing that I haven’t tried?
-What are the real world security implications of this warning?

This topic was automatically closed 60 days after the last reply. New replies are no longer allowed.