I want to stop ALL autoplay

Yes please, I would love a browser which doesn’t do this user-hostile stuff. Devs please fix.

I totally agree. What am I missing here? I joined Brave to have control. Where is the turn off autoplay button.

3 Likes

Welcome to Brave Community! I absolutely agree. We need to keep this topic alive. It’s embarrassing that we have to have a work-around for this still

I’ve tried Autoplaystopper with it blocking everything, but it stopped nothing. I’m reluctant to try Autoplay Blocker at this point. But this bandwidth wasting nonsense on websites needs to stop, and Brave needs to help.
Is there anything that currently works, and is safe, on this current version of Brave?

Installing AutoplayStopper stopped videos autoplaying for me and for others. YMMV.

For more than a year (installed 1 Sept 2019) I’ve been using AutoplayStopper. The extension does what it claims to do; others report similar satisfaction.

Mid-May 2020, a Brave moderator suggested Brave may have a fix in the works. Maybe. The Brave moderator then closed discussions of this issue in that thread.

The not-so-good news — resolving this (and other issues) with extensions has potential downsides: https://krebsonsecurity.com/2020/03/the-case-for-limiting-your-browser-extensions/

I am new here. this issue seems to be years old. is anyone at brave listening to anything in the forum??

The option is stll available, you can disable autoplay just here : brave://settings/content/autoplay.

1 Like

Thanks for the suggestion.

As others have noted in discussions about Autoplay, there’s apparently a “white list” (inaccessible to mere mortals) that permits Autoplay on some sites even when Brave’s Autoplay preference is toggled “Off”.

I have AutoplayStopper installed. I diabled it and, following your suggestion, toggled “Autoplay” to “Off” in Brave’s settings. I then visited a site known to me to have aggressive Autoplay behavior.

Sure enough, with AutoplayStopper disabled, even with “Autoplay” toggled to “off” in Brave’s settings, I was deluged with autoplaying content.

The solution for me: install AutoplayStopper. It works.

I’ve enjoyed my brief foray into Brave on mobile. However the video autoplay does need resolving on Android. There don’t appear to be addons to stop it and video play is particularly invasive and irrating on mobile. Tried changing the site setting but this doesn’t work for some sites.

If others have hints tips or similar experiences I’d love to know. Is there is a plan to address this?

Rolleroo

P. S. And on a couple of sites it freezes the page.

I agree. Videos don’t autoplay on Windows but they still autoplay on Android.

I have the same issue here. I selected ‘block’ for autoplay in the site settings yet videos are still autoplaying.

Still a major issue, along with many others that crash the browser continually. How is this a mainstream browser with so many errors? What can we do to help?? Something needs to change, but I don’t want to give up after such a good start.

  1. Go to brave://settings/content?search=autoplay
  2. Click additional permissions.
  3. Set autoplay to block


    It works for me.
1 Like

Not on mobile, where this is a bigger issue with data, sorry.

1 Like

So something really weird happens with brave, specially on youtube. So, I have the settings of default turn off autoplay globally.

Now, If you open youtube homepage and then simply click a video, it does not autoplay, but if you open the video in a new tab and then switch to that tab, it starts playing as soon as you switch to that tab.

Not sure why this is happening.

I’d like to see animated GIFs included in this category, as I’m fed up with sites now using them in article headers, for example AndroidPolice has them and they are very annoying https://www.androidpolice.com/2021/04/20/google-photos-has-a-category-for-all-of-your-memories-and-here-they-are/

If a GIF image (animated or not) belongs to a tracking ad network, Brave already blocks it.
If you want to block animated GIFs in general, or other images, there are lots of extensions. Try this one https://chrome.google.com/webstore/detail/stop-animations/gemmknjnneiojfjelmgappppbaneikda but there are many more.

I’ve tried many of them and not one works very well, and almost all of them haven’t been updated in several years. The one you directly mention works by taking a screen-shot of the entire page to “freeze” the action and then resumes when you press “Escape” - it’s just a kludge for a feature that should be part of the browser - I don’t want the extra data downloaded by these minute-plus GIFs which has extremely poor compression…

I’ve used “Block image” for a long time and it works perfectly https://chrome.google.com/webstore/detail/block-image/pehaalcefcjfccdpbckoablngfkfgfgj Light and fast. It’s not been updated simply because it still works. It’s very aggressive though.

Salut meci de m’aider