I just cant make it to work (BAT, rewards, vallet). About to give up

I’m using Brave on several devices as my main browser. Mostly on my Android, but also on my Linux desktop and laptop. For years now. BAT was just a nice bonus, never got too much time to completely configure it but slowly over time I did spend time and configured stuff, became a verified publisher, linked to Uphold, made tipping work.

I was at that point several times in last years, where I thought everything works finally. And several times I realized it stopped. Zero BAT rewards, tipping not working, tipping feature not visible at all, etc. The other day I decided to reinstall and test everything again, losing my BAT of course. Here is the situation:

  1. Android - Brave 1.19.86 - “send a tip” and “verified publisher” features not visible at all.
  2. Android - Brave beta 1.20.92 - everything seems to work after install
  3. Linux - Brave 1.15.75 - “send a tip” and “verified publisher” features not visible at all.
    … just now, retried everything, and now point 1, Android Brave seems to works. I
    have no idea how it started to work again and why but I’m pretty sure it’s not for long.

Now more stuff on Linux Brave. My wallet says “disconnected” so I click that, then “login”, and that leads me to the page at 'brave://rewards/uphold… and I’m logged in. The top right box on the page says “wallet verified” but click on the triangle icon in the address bar still says “Disconnected” and stays like that no matter what I do.

I know that inability to link multiple browsers to the same wallet is not a bug, but it adds to the frustration. Something that was not important at all (BAT) and started as a nice bonus, now is poking me in the eye every time I open Brave.

Thank you for reporting! Please DM with the following information:

  • Copy/paste your Wallet ID (found on brave://rewards-internals)
  • Your OS and Brave version (first three lines in brave://version)
  • A screenshot of your Rewards panel in Settings --> Brave Rewards.

This will help to speed up the troubleshooting. Thank you in advance!

About to give up

FWIW I already gave up. I haven’t received ads since December 31. I DM’ed several employees but they didn’t fix the issue (I got one answer, stating everything was fine). Curiously, when I use a VPN through a server in Germany, I start to get ads. However, I don’t want/need to use a VPN all the time. So I got rid of ads, BATs, you name it, altogether.

I’m using Brave on several devices as my main browser.

Same here: I still use Brave as my main browser both on desktop and on mobile. Without BATs, though. I like other features, but I’m fed up with all the BAT/crypto stuff, which doesn’t work and/or pays too little. Actually, I wish Brave could release a version without BATs: it would be lighter and more convenient, in this case.

PS, I was forgetting: I have no intention of signing up for “Uphold”. I trust Brave, but not Uphold.

Me too, i had no intention of singing up for Uphold but i had no other choice.
Please Brave, let’s people free to choose their own wallet to receive rewards !

@gmacar Thanks you for showing me this topic. Look this one:

I remember having read somewhere about Uphold being a parasitic company. If I find the topic, I will show it here

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.