I installed the right Brave. I didnt install it from GitHub. But I still get the error here. https://i.imgur.com/pNVz9Lo.png

I can’t update my Brave Browser. I am on Version 1.38.119 and I want to update it as I think there is a new update. But it doesn’t let me, even tho I downloaded the correct version of the Browser.

@Nem_esis

Locations for getting Brave Browser latest stable release:

Brave: https://brave.com/download/

GitHub (click version number of interest): https://github.com/brave/brave-browser/blob/master/CHANGELOG_DESKTOP.md