I honestly wish Brave would stop treating users like an idiot and allow us to use unsigned extensions!

I thought Brave was supposed to give complete power and control for the user:


I want to run a privacy respecting extension and I get this stup!d message, disallowing me to even enable it, even though I have had developer options enabled. Why can’t I make my own decisions knowing what is safe and not safe.

This tempts me to move to an alternative browser such as ungoogled-chromium

1 Like


Alternative extension installation methods are explained below.

  1. Go to https://developer.chrome.com/docs/extensions/mv3/external_extensions/#faq-registry

  2. Follow steps about how to add extension; steps depend on your OS.

  3. Open Brave and add extension (below image for Windows 64).

Is this issue with any chromium-based browser?

Thanks for the steps

Works straighforward in MS Edge!

Yes, it’s Chromium. A lot of people in the past were trying to bypass it by using extensions like TamperMonkey where they’d copy/paste extension data to make it work. You can read a bit on that at https://superuser.com/questions/767286/re-enable-extensions-not-coming-from-chrome-web-store-on-chrome-v35-with-enhan within different comments.

Btw, @CerealLover and @joe232 can y’all try something?

So if I’m following what you’re saying, you have a .crx file that you want to install in Brave Browser? If that is the case, here is what to do:

  1. Unzip it to a folder. 7zip should do the trick. Put it somewhere where you won’t delete it, of course.
  2. Go to brave://extensions
  3. Enable ‘Developer mode’. The toggle is on the top-right of the tab.
  4. Press ‘Load unpacked’ and select the unzipped folder.
  5. Success.

I noticed those instructions at https://www.reddit.com/r/brave_browser/comments/nuc1he/comment/h0x0i13/?utm_source=share&utm_medium=web2x&context=3 and wondering if still works. I’m assuming it might. If so, might be another way for you. Not sure if one step is any better than the other.

1 Like

THanks I will give this a try then :slight_smile:

This topic was automatically closed 60 days after the last reply. New replies are no longer allowed.