I have to re-login to websites every time I restart the browser

Note that I’m using Zorin OS 15.3 which is a Ubuntu derivative and I have Brave installed through the repo (i.e. not using a snap, etc.). And this problem wasn’t there until today.

Okay, so I have several websites that I tick the ‘stay logged in’ or similar box. When I exit the browser and come back to the same sites, it’s “forgotten” that I was logged in. I haven’t tried a tonne of websites yet but it happens in Prime Video (Amazon), CuriosityStream (two sites I use a lot) and this website.

To reproduce this issue, I,

  1. Log into a website and choose to stay logged in.
  2. Exit Brave by clicking the close button.
  3. Start Brave up again and go to same website and it tells me to log in again.

What I expect to happen is not having to log in every time I re-open Brave and go to the website where I chose to ‘stay logged in.’ This hasn’t happened before except when I accidentally cleared my info and hadn’t removed the check for cookies from 'Clear Browsing Data. This just started happening yesterday if I recall correctly (also been trying Firefox again so it can be confusing).

Brave Version: 1.23.73

Clear Browsing Data → Cookies and Other Site Settings UNTICKED in Basic, Advanced & Exit
Cookies & Other Site Data → Clear cookies and site data when you quit Brave UNTICKED
General cookie settings set to BLOCK THIRD-PARTY COOKIES
Under the cookies stored, the sites are listed there even after exiting and restarting Brave
I have two extensions installed - LastPass and Pocket. I need both. And they’ve never caused an issue before. I don’t want to disable them as I can’d do without them.

Things I’ve tried to fix the issue:

Tried this over and over, logging in, exiting the browser, coming back and it does the same thing, every single time.
Putting the websites into ‘Sites that can always use cookies’
Removing Brave and reinstalling it
Removing Brave and purging config files and reinstalling
Noticing that the config files weren’t deleted so removed it again, deleted the Brave folder with config info and reinstalled

I really like Brave. I honestly think it’s the best browser out there but this issue is driving me crazy. I hope somebody can help. I’m read to dig into whatever settings are necessary to fix this. I’ll use Firefox in the meanwhile and occasionally check back with Brave, especially if an update is pushed out.

Thanks for any help.

1 Like

Hello @rogue5

go to brave://settings/cookies and make sure to uncheck this Clear cookies and site data when you quit Brave

make sure nothing is selected on exit brave://settings/clearBrowserData

if that did not work just disable your extension just for testing and see if it work or not

if it work then renable them one by one till you get the one that cause the issue

if those did not work then try to create new profile and see if it work fine there

Thanks for your help, justsomeone1!

I already tried that as noted in my original post but thanks anyway.

I mostly tried that one. I made sure that cookies and site data wasn’t selected on exit there. I changed it to making sure everything wasn’t selected and the problem still existed.

I tried disabling the two extensions I had installed. It didn’t help, sadly.

if those did not work then try to create new profile and see if it work fine there

I had high hopes for that suggestion. It wasn’t something I thought of. I forgot profiles even existed. I created a new profile, left everything in Brave at the defaults, double-checked the settings you mentioned in your first two suggestions and still lost the logged in status (used this website to check). after I exited and restarted. I made sure that I was in the newly-created profile, too.

Sigh. I swear this problem didn’t exist a few days ago. I don’t know what changed. I had Brave freeze-up on me a couple of times but I removed it completely (including config files) and re-installed it.

Any other suggestions, anybody?

could you change the shield setting to advanced view then make it allow all cookies and see if it work or not

Thanks for your reply.

Okay, just tried it but alas, it didn’t work.

I also checked the shield setting to see if it still says ‘allow all cookies’ and it does. I checked in settings to make sure it was still set there and it was.

Also wanted to note that that when I check under brave://settings/siteData the Brave Community cookies are there. Just wanted to mention it in case it’s important.

you very welcome
let me ask @Mattches from the team to help us here
and have a nice day for both of you :slight_smile:

Oh, good. I don’t know anyone here but I hope to get to know you guys and help later where I’m able to. I just realized how damn slow Firefox is on pages with a lot of ads so like to get back to it. I guess the other alternative is just to leave Brave open so I don’t ever get logged out, at least not until a power outage hits. :slight_smile:

I noticed there was an update so I was hopeful that maybe it would fix the problem but unfortunately it didn’t. I did a complete fresh install of Brave a couple of times. It kept leaving the Brave data inside .config even when I told Synaptic to remove it completely so I went in and deleted the directory myself before re-installing.

The really weird part to me is that the cookies are there. For example, I tried Netflix and it stores the cookies, more when the shields are off. But when I come back to the website it doesn’t appear to be reading them. Even though the cookies are there. I have no idea why.

If anyone knows any way of looking at the settings in Brave directly (like through a file I can open in an editor), let me know. There are a lot of files in .config/BraveSoftware/Default, which I believe is where the default profile is stored. My bookmarks are there anyway after re-importing them. But I don’t know what file to look for where the settings are stored if they can even be examined. Even if the file can’t be examined, maybe it’s a permission issue as in having been installed with a permission that can write but not read? I can fix that but I need to know what file to fix.

Any help would be appreciated.

any file/folder has write permission has already read permission

there should be file called cookies and cookies-journal inside the folder you mentioned

that expected but what you mean with

do you install brave using the official way from here https://brave.com/linux/#linux using ubuntu/debian section

Thank you for your reply.

Oh, good point. Not sure why I hadn’t thought of that.

I found the files, the cookies file appears to be an SQLite database. When I open it in DB Browser it only has the structure, no data. The second file appears to be just a text file and it has nothing in it either. What’s supposed to be in these files? Btw, what I was asking if there was one file somewhere that has all of Brave’s settings, for everything including cookie settings, just to see if what I was setting in the Settings was what was in a settings file for it. Probably overthinking this.

I installed it initially using those instructions and then when I removed and re-installed I used Synaptic. That should be the same as doing it in the terminal, no?

When I was removing it, I used the ‘Remove Completely’ option in Synaptic which is supposed to remove settings associated with a package so I thought it would remove the BraveBrowser folder inside of .config but I guess not.

I found the file, a text file called Preferences. Doi! should have thought of that. Not a very easy file to read though, everything is mashed together.

Update: Discovered it’s actually a JSON file and found a way to view that. I searched for references to cookies for the settings and only found 2, both of which related to clearing on exit and both were set to false.

i would recommend to install using the official one but after you remove the current one and also remove the folder of brave that inside .config folder

in ubuntu which zorion is based on it when install brave using snap sometime it has wierd and unexpected issue so try to use the official one and see how it work

i did not use synaptic before so not sure if it make isolated storage (same idea when you install app on android) or what and if it do that then maybe it make some conflict

I should have mentioned it but I am using the official package not the snap which had the warning. I also deleted the Brave directory inside of .config.

I did notice one thing that is odd. I looked up the cookie for this website (see attachment). Note the cookie expiry date.

I can’t check the cookie in Firefox but I don’t think I have to re-log into this website after opening it up again. So I’m guessing the expiry date isn’t the same. This community forum doesn’t set cookies to expire at log out, does it?

I tried re-installing it at the terminal instead of using synaptic. It does the same thing.

This is all so weird. If you think of anything else to try another day, let me know. I appreciate the time you’ve spent trying to help me fix this.

i get 2 cookies for this site the one you mentioned and another one called _t which expire at the end of june

just to make sure the it’s os issue
does zorion has live cd option that make you boot from an flash drive that has the zorion image and it work with out installation same as ubuntu and fedora
if yes then create a live cd on an empty flash stick then boot from it then do not do anything except to go to the brave website and open the terminal and install it
then test if it keep you login after closing the browser

and you very welcome i also learn from you how this issue can be fixed so it’s a win win

That works! I’m writing you from the live usb version. And five other websites are open in tabs that work after shutting down and restarting Brave.

That could mean the OS, or rather all the other programs and cruft that are installed. as you say…

The flash drive version that I booted from doesn’t have its updates and I’m not sure I could get them. I mean, the option is there but the drive might not be big enough to handle them all. So it could be something in one of the updates, maybe a library file that was updated that broke Brave somehow or there is some configuration file(s) for Brave outside of the .cache and .config directories and it’s messing things up. Because I have removed, deleted those directories, and re-installed Brave countless times now.

And there are many other programs I have installed in my normal (installed) version of Zorin that I probably can’t install here.

I going to try to see if I can do the updates on this flash drive but I’m definitely not going through the work of installing my apps. It’ll be interesting to see if Brave shows the bad behaviour I experience on the Zorin I have installed to my SSD.

Thanks for the suggestion to try this. I’ll see where I get with the updates now.

let me ask @fmarier from the team if he has any idea about that behaviour

and have a nice day both of you :slight_smile:

1 Like

I wasn’t able to do the updates on the flash drive but that’s no matter. I didn’t really expect that to work.

And then I was using Zorin the next day and the panel disappeared! So I decided I was due for a re-install and since my laptop is only an i3-1.4 GHz with 4 GB of RAM, I decided to go with Lubuntu for best performance. Zorin Lite was laggy for me anyway.

After installing Lubuntu and Brave, it’s remembering when I’m logged into a site. :smile: I’m going to image the system before anything else happens! But for now, all is good in my computer universe.

I wish I could have gotten to the bottom of the problem but at least it’s fixed. Thanks again for your help, @justsomeone1 .

glad to know that it work fine with your new installation
and you very welcome :slight_smile: